summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-02-05 13:07:34 +0100
committerPacho Ramos <pacho@gentoo.org>2023-02-05 13:07:34 +0100
commit6922b0fbb27b3eddc4c2797a1b874205db7c3a7e (patch)
treeaf1e43d23b56291b6d6aa101e636c2e3f2315ebb
parentpypi.eclass: Make package optional as well (diff)
downloadgentoo-6922b0fb.tar.gz
gentoo-6922b0fb.tar.bz2
gentoo-6922b0fb.zip
x11-themes/papirus-icon-theme: add 20230104
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--x11-themes/papirus-icon-theme/Manifest1
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20230104.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/Manifest b/x11-themes/papirus-icon-theme/Manifest
index cfd54c5cbcf2..fe40a156f274 100644
--- a/x11-themes/papirus-icon-theme/Manifest
+++ b/x11-themes/papirus-icon-theme/Manifest
@@ -1 +1,2 @@
DIST papirus-icon-theme-20221201.tar.gz 33494699 BLAKE2B 546c7b3530fc039821e2d183f426d4131182c5c923c51b86367352c39d40c7f96e4f1f3e842d1c286db68685ecc5afa5898de2605f299eff781f7d1a801ec3e9 SHA512 2c4f73f3036a66efccbc6c19d6e571782f0d8549a4bcee55d85413f4960dc1941a15cdc667760d73d5e75211444d4c4b9814bdd6294037719dd5cfe03a2ad445
+DIST papirus-icon-theme-20230104.tar.gz 33527798 BLAKE2B 9aa80a3611f0a39aa0fabeb0a20a7d901ed983c046208784bbd268151a7668adf99d0e4d9df9efe544864278dc2ff417a40ab581610f11d204a4288e68173adb SHA512 c07adc6258e9c0b37b250efae91825004b5b440304b9a901dbccec90fe683eee6871f5bf3205e79ee1bf44fe13ce5f014cbfc99b1bb6488e82bd6b0b8b730bfa
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20230104.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20230104.ebuild
new file mode 100644
index 000000000000..4460fa17b1f7
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20230104.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit xdg
+
+DESCRIPTION="Free and open source SVG icon theme"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+src_prepare() {
+ default
+ # https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/issues/3241
+ cd Papirus/128x128/apps/ || die
+ ln -s beneath-a-steel-sky.svg bass.svg || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r Papirus{,-Dark,-Light}
+
+ # Install variants designed for elementary OS and Pantheon Desktop only
+ doins -r ePapirus{,-Dark}
+}