summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-22 23:02:56 +0000
committerSam James <sam@gentoo.org>2021-03-23 04:48:55 +0000
commit693251517b99f90c63717abc0056f925a608cf60 (patch)
tree3804f48f3e5e0b6bb9f35132f15b84d5522126bf
parentnet-analyzer/netcat: tiny style changes (diff)
downloadgentoo-693251517b99f90c63717abc0056f925a608cf60.tar.gz
gentoo-693251517b99f90c63717abc0056f925a608cf60.tar.bz2
gentoo-693251517b99f90c63717abc0056f925a608cf60.zip
net-misc/endlessh: style changes
* Bash tests, not POSIX * Drop unneeded variables Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/endlessh/endlessh-1.1-r1.ebuild9
-rw-r--r--net-misc/endlessh/endlessh-9999.ebuild11
2 files changed, 5 insertions, 15 deletions
diff --git a/net-misc/endlessh/endlessh-1.1-r1.ebuild b/net-misc/endlessh/endlessh-1.1-r1.ebuild
index d1022eecb731..6b88d25a68ab 100644
--- a/net-misc/endlessh/endlessh-1.1-r1.ebuild
+++ b/net-misc/endlessh/endlessh-1.1-r1.ebuild
@@ -8,7 +8,7 @@ inherit systemd toolchain-funcs
DESCRIPTION="SSH tarpit that slowly sends and endless banner"
HOMEPAGE="https://github.com/skeeto/endlessh"
-if [ ${PV} == "9999" ] ; then
+if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/skeeto/${PN}.git"
else
@@ -18,11 +18,6 @@ fi
LICENSE="Unlicense"
SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-BDEPEND=""
PATCHES=(
"${FILESDIR}"/${PN}-1.1-syslog-help.patch
@@ -55,7 +50,7 @@ src_install() {
systemd_dounit util/endlessh.service
- insinto /usr/share/"${PN}"
+ insinto /usr/share/${PN}
doins util/{pivot.py,schema.sql}
}
diff --git a/net-misc/endlessh/endlessh-9999.ebuild b/net-misc/endlessh/endlessh-9999.ebuild
index 8d77c61d5a7e..6a1cf2d9165f 100644
--- a/net-misc/endlessh/endlessh-9999.ebuild
+++ b/net-misc/endlessh/endlessh-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ inherit systemd toolchain-funcs
DESCRIPTION="SSH tarpit that slowly sends and endless banner"
HOMEPAGE="https://github.com/skeeto/endlessh"
-if [ ${PV} == "9999" ] ; then
+if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/skeeto/${PN}.git"
else
@@ -18,11 +18,6 @@ fi
LICENSE="Unlicense"
SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-BDEPEND=""
src_prepare() {
default
@@ -51,7 +46,7 @@ src_install() {
systemd_dounit util/endlessh.service
- insinto /usr/share/"${PN}"
+ insinto /usr/share/${PN}
doins util/{pivot.py,schema.sql}
}