summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-12 20:41:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-12 20:42:06 +0100
commit6938287904ed038fa8c9d7d392f86f1b051eec55 (patch)
treef474d2f7d831926c9f545c59bd3050e9d29159cf
parentdev-ml/eliom: bump to 6.0.0 (diff)
downloadgentoo-6938287904ed038fa8c9d7d392f86f1b051eec55.tar.gz
gentoo-6938287904ed038fa8c9d7d392f86f1b051eec55.tar.bz2
gentoo-6938287904ed038fa8c9d7d392f86f1b051eec55.zip
dev-ml/ocsigen-toolkit: initial import; ebuild by me.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-ml/ocsigen-toolkit/Manifest1
-rw-r--r--dev-ml/ocsigen-toolkit/metadata.xml8
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-0.99.ebuild52
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild52
4 files changed, 113 insertions, 0 deletions
diff --git a/dev-ml/ocsigen-toolkit/Manifest b/dev-ml/ocsigen-toolkit/Manifest
new file mode 100644
index 000000000000..555f5a08c8c2
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/Manifest
@@ -0,0 +1 @@
+DIST ocsigen-toolkit-0.99.tar.gz 68978 SHA256 fd42765a5f0d9297607160523bb99c4a6b2b6ef25b4c1464b6065bc98caea54b SHA512 a46577b4627a19a85c4f628dc47bfb81ba8da641dcf08e97df02f236e0a328086d8395aa165a9e82b42b3254c7d04f7d763c12cd7495f427a6d681544ad7963b WHIRLPOOL a496e41ec1974c0c841f4e154182a407326884067ffd389a83824b5957fe1f320643856acf422239e67d4a7a5dace1ab1f703c869b87feb6f8c16855cc78ce36
diff --git a/dev-ml/ocsigen-toolkit/metadata.xml b/dev-ml/ocsigen-toolkit/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-0.99.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-0.99.ebuild
new file mode 100644
index 000000000000..08cdc51e1ae1
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-0.99.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="User interface widgets for Ocsigen applications"
+HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt debug"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-toolkit"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ >dev-ml/js_of_ocaml-2.7:=
+ >=dev-ml/eliom-5.1:=[ppx]
+ dev-ml/ppx_deriving:=
+ dev-ml/calendar:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND}
+ dev-ml/opam"
+
+src_compile() {
+ emake \
+ DEBUG="$(usex debug yes no)" \
+ NATIVE="$(usex ocamlopt yes no)" \
+ all
+}
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc README.md
+}
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
new file mode 100644
index 000000000000..08cdc51e1ae1
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="User interface widgets for Ocsigen applications"
+HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt debug"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-toolkit"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ >dev-ml/js_of_ocaml-2.7:=
+ >=dev-ml/eliom-5.1:=[ppx]
+ dev-ml/ppx_deriving:=
+ dev-ml/calendar:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND}
+ dev-ml/opam"
+
+src_compile() {
+ emake \
+ DEBUG="$(usex debug yes no)" \
+ NATIVE="$(usex ocamlopt yes no)" \
+ all
+}
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc README.md
+}