summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-30 20:26:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-30 20:27:34 +0200
commit693e3888cd94ce96cd2e5f63242d751d12aa2f1f (patch)
tree3415677eac1a6536554ce0029cda8a103c3198c7
parentsys-devel/lld: Revert "Add zstd support to 16.x" (diff)
downloadgentoo-693e3888.tar.gz
gentoo-693e3888.tar.bz2
gentoo-693e3888.zip
sys-devel/llvm: Revert "Add zstd support in 16.x"
Unfortunately, LLVM's cmake files leak the dependency on otherwise non-existing zstd targets, so everything building against LLVM fails now. Reverts: 70bf3a8996b9a14b0e28d7e367275a20f6d0cffc Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/llvm/llvm-16.0.0.9999.ebuild22
-rw-r--r--sys-devel/llvm/llvm-16.0.0_pre20220930.ebuild22
2 files changed, 6 insertions, 38 deletions
diff --git a/sys-devel/llvm/llvm-16.0.0.9999.ebuild b/sys-devel/llvm/llvm-16.0.0.9999.ebuild
index d0153e31a64d..9171387473ba 100644
--- a/sys-devel/llvm/llvm-16.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-16.0.0.9999.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
-inherit cmake llvm.org multilib multilib-minimal pax-utils \
- python-any-r1 toolchain-funcs
+inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
+ toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -19,10 +19,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="$(ver_cut 1)"
KEYWORDS=""
-IUSE="
- +binutils-plugin debug doc exegesis libedit +libffi ncurses test xar
- xml z3 zstd
-"
+IUSE="+binutils-plugin debug doc exegesis libedit +libffi ncurses test xar xml z3"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -35,7 +32,6 @@ RDEPEND="
xar? ( app-arch/xar )
xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )
- zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
DEPEND="
${RDEPEND}
@@ -341,13 +337,6 @@ multilib_src_configure() {
ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)
ffi_ldflags=$($(tc-getPKG_CONFIG) --libs-only-L libffi)
fi
- if use zstd; then
- cat > "${BUILD_DIR}"/zstdConfig.cmake <<-EOF || die
- add_library(zstd::libzstd_shared SHARED IMPORTED)
- set_target_properties(zstd::libzstd_shared PROPERTIES
- IMPORTED_LOCATION "${EPREFIX}/usr/$(get_libdir)/libzstd$(get_libname)")
- EOF
- fi
local libdir=$(get_libdir)
local mycmakeargs=(
@@ -377,7 +366,6 @@ multilib_src_configure() {
-DLLVM_ENABLE_EH=ON
-DLLVM_ENABLE_RTTI=ON
-DLLVM_ENABLE_Z3_SOLVER=$(usex z3)
- -DLLVM_ENABLE_ZSTD=$(usex zstd)
-DLLVM_HOST_TRIPLE="${CHOST}"
@@ -386,10 +374,6 @@ multilib_src_configure() {
# used only for llvm-objdump tool
-DLLVM_HAVE_LIBXAR=$(multilib_native_usex xar 1 0)
- # workaround llvm requiring cmake files from zstd
- -Dzstd_DIR="${BUILD_DIR}"
- -DLLVM_PREFER_STATIC_ZSTD=FALSE
-
-DPython3_EXECUTABLE="${PYTHON}"
# disable OCaml bindings (now in dev-ml/llvm-ocaml)
diff --git a/sys-devel/llvm/llvm-16.0.0_pre20220930.ebuild b/sys-devel/llvm/llvm-16.0.0_pre20220930.ebuild
index d0153e31a64d..9171387473ba 100644
--- a/sys-devel/llvm/llvm-16.0.0_pre20220930.ebuild
+++ b/sys-devel/llvm/llvm-16.0.0_pre20220930.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
-inherit cmake llvm.org multilib multilib-minimal pax-utils \
- python-any-r1 toolchain-funcs
+inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
+ toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -19,10 +19,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="$(ver_cut 1)"
KEYWORDS=""
-IUSE="
- +binutils-plugin debug doc exegesis libedit +libffi ncurses test xar
- xml z3 zstd
-"
+IUSE="+binutils-plugin debug doc exegesis libedit +libffi ncurses test xar xml z3"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -35,7 +32,6 @@ RDEPEND="
xar? ( app-arch/xar )
xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )
- zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
DEPEND="
${RDEPEND}
@@ -341,13 +337,6 @@ multilib_src_configure() {
ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)
ffi_ldflags=$($(tc-getPKG_CONFIG) --libs-only-L libffi)
fi
- if use zstd; then
- cat > "${BUILD_DIR}"/zstdConfig.cmake <<-EOF || die
- add_library(zstd::libzstd_shared SHARED IMPORTED)
- set_target_properties(zstd::libzstd_shared PROPERTIES
- IMPORTED_LOCATION "${EPREFIX}/usr/$(get_libdir)/libzstd$(get_libname)")
- EOF
- fi
local libdir=$(get_libdir)
local mycmakeargs=(
@@ -377,7 +366,6 @@ multilib_src_configure() {
-DLLVM_ENABLE_EH=ON
-DLLVM_ENABLE_RTTI=ON
-DLLVM_ENABLE_Z3_SOLVER=$(usex z3)
- -DLLVM_ENABLE_ZSTD=$(usex zstd)
-DLLVM_HOST_TRIPLE="${CHOST}"
@@ -386,10 +374,6 @@ multilib_src_configure() {
# used only for llvm-objdump tool
-DLLVM_HAVE_LIBXAR=$(multilib_native_usex xar 1 0)
- # workaround llvm requiring cmake files from zstd
- -Dzstd_DIR="${BUILD_DIR}"
- -DLLVM_PREFER_STATIC_ZSTD=FALSE
-
-DPython3_EXECUTABLE="${PYTHON}"
# disable OCaml bindings (now in dev-ml/llvm-ocaml)