summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-10 20:57:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-10 21:00:12 +0100
commit694bab8c897ab30ebaa9c248cbf6c3c0bc919d5a (patch)
treeafb395ca5eb908b5657f5b113f1d2a9abb15f04b
parentdev-python/pylama: Bump to 8.3.7 (diff)
downloadgentoo-694bab8c897ab30ebaa9c248cbf6c3c0bc919d5a.tar.gz
gentoo-694bab8c897ab30ebaa9c248cbf6c3c0bc919d5a.tar.bz2
gentoo-694bab8c897ab30ebaa9c248cbf6c3c0bc919d5a.zip
dev-python/pycountry: Bump to 22.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycountry/Manifest1
-rw-r--r--dev-python/pycountry/pycountry-22.1.10.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pycountry/Manifest b/dev-python/pycountry/Manifest
index 9d5f70307bdd..3df4a19e3177 100644
--- a/dev-python/pycountry/Manifest
+++ b/dev-python/pycountry/Manifest
@@ -1 +1,2 @@
DIST pycountry-20.7.3.tar.gz 10137217 BLAKE2B 2b32d450a1d16eab95e0c1ab6cae3bf89c07742d48cf6f8473854119ac0483b5490523e03e823c9b314231983f39d1c8bf595aac201756fee9897a8d15a84c08 SHA512 df88a34307a4275267a7f3af282b73ca5e762c49ad158bfcd39b97c5d852bf045bcfe72351fc6f232c55003a7c4b0a04801eb562ba65ed5d599bd45b2bd3bc58
+DIST pycountry-22.1.10.tar.gz 10060795 BLAKE2B 51672b2e08e48528797e57e6a546261d4ceee0af364d5c943f243a5956008ffc417b02e553f376c252bfbfbf76af40585c9f910815a9c2943ff88be6fb9d4180 SHA512 93e5737df29affe5bbf8a2aa2caef59727adcc198eab301a5ddbc4275e32955cec0de9ab2820470a8cf87b0c0a9d48bfddd18411d93a700212aba8372e5a52b4
diff --git a/dev-python/pycountry/pycountry-22.1.10.ebuild b/dev-python/pycountry/pycountry-22.1.10.ebuild
new file mode 100644
index 000000000000..4fdb4fe48709
--- /dev/null
+++ b/dev-python/pycountry/pycountry-22.1.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+# The package uses pkg_resources to determine its version
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://github.com/flyingcircusio/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~riscv ~sparc ~x86"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests --install pytest
+
+# https://github.com/flyingcircusio/pycountry/pull/51
+PATCHES=( "${FILESDIR}/pycountry-20.7.3-fix-tests-for-pypy3.patch" )