summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-27 14:31:17 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-27 14:34:47 +0200
commit6959ad89eb8358457ee751e36f1bff856a68fd9b (patch)
tree58955e88bc9d26fe8f5829b75e0247d70a0316a9
parentapp-benchmarks/siege: Drop old (diff)
downloadgentoo-6959ad89.tar.gz
gentoo-6959ad89.tar.bz2
gentoo-6959ad89.zip
app-arch/snappy: Revert "Drop old"
Revdeps need to be fixed to stop relying on static-libs first.
-rw-r--r--app-arch/snappy/Manifest1
-rw-r--r--app-arch/snappy/snappy-1.1.3-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/snappy/Manifest b/app-arch/snappy/Manifest
index 60e8583cc5d2..8f0b00eb8655 100644
--- a/app-arch/snappy/Manifest
+++ b/app-arch/snappy/Manifest
@@ -1 +1,2 @@
+DIST snappy-1.1.3.tar.gz 1509026 BLAKE2B d8dbb6e92d1788f7b13e6e36aa0297cfcb28d664fb625d0798831ccd00de818675c224821359cc66f38f274da248725737510a85b01a36efe07aa4c9a8bcfda4 SHA512 4c4f47c657a072989179be9df0e5e98d14f4a67c27ec7ae0e5a15d14289a75d4e266bc6c5c89723f3e9860408ffcc7138a815f8ad9299407c4a1946fc00ab5bf
DIST snappy-1.1.7.tar.gz 1090550 BLAKE2B e389c96e093de5db92b896a7fa17a90d3ad0be07972e279321f24875f0f0c8c704ff478f4902a6356d458f93c249e3e06424d5a4efc9753a23ab12b7ee83a088 SHA512 32046f532606ba545a4e4825c0c66a19be449f2ca2ff760a6fa170a3603731479a7deadb683546e5f8b5033414c50f4a9a29f6d23b7a41f047e566e69eca7caf
diff --git a/app-arch/snappy/snappy-1.1.3-r1.ebuild b/app-arch/snappy/snappy-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..56a519b607b3
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools multilib-minimal
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://github.com/google/snappy"
+SRC_URI="https://github.com/google/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ # Avoid automagic lzo and gzip by not checking for it
+ sed -i '/^CHECK_EXT_COMPRESSION_LIB/d' configure.ac || die
+
+ # don't install unwanted files
+ sed -i 's/COPYING INSTALL//' Makefile.am || die
+
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --without-gflags
+ --disable-gtest
+ $(use_enable static-libs static)
+ )
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED%/}"/usr/lib* -name '*.la' -delete || die
+}