summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-01-15 12:50:49 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-01-15 12:51:08 -0600
commit695a0ca947365c674e12f12eb67767c8b00b786a (patch)
tree1841a90f746c4e7c91a41404363a3a356a327d19
parentsys-cluster/cinder: 16.2.1 stable amd64/x86 (diff)
downloadgentoo-695a0ca947365c674e12f12eb67767c8b00b786a.tar.gz
gentoo-695a0ca947365c674e12f12eb67767c8b00b786a.tar.bz2
gentoo-695a0ca947365c674e12f12eb67767c8b00b786a.zip
dev-libs/leatherman: 1.12.4 stable amd64/x86 with cleanup
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-libs/leatherman/Manifest1
-rw-r--r--dev-libs/leatherman/leatherman-1.12.3.ebuild61
-rw-r--r--dev-libs/leatherman/leatherman-1.12.4.ebuild4
3 files changed, 2 insertions, 64 deletions
diff --git a/dev-libs/leatherman/Manifest b/dev-libs/leatherman/Manifest
index ab3a08ba137b..0e2857d871b5 100644
--- a/dev-libs/leatherman/Manifest
+++ b/dev-libs/leatherman/Manifest
@@ -1,3 +1,2 @@
DIST leatherman-1.12.2.tar.gz 816010 BLAKE2B 4b7b00b88ef0ba5cb01405aa24fd5ff72918a122cc8a1c0a029e374152964f77afa29a1f503ed5863a39bd13aa808dba2a0b351f65756e97c8e2e8408358cbfc SHA512 9be8333b616bd9772f234474ae874c7214fa0c1bc4658ff042233d6e1683cc61b63d666d750297c79a8058490e42c8b2ff8999cb7f04aa329644f52540e43bde
-DIST leatherman-1.12.3.tar.gz 816018 BLAKE2B 6245284856613b99df2ce412e497ba69fe1a016a82ca5ea7f78ba591dc287e2daef051214b303c1cc463efb537354a01ad6c57688f244382b3843b8bfdad6f3e SHA512 83f785ba7c69032e2c9c7f2fb07aa5c100ed9e1a81c88ece19d7a96647b9a46927b99fd7144c08d697863e44553f00adf6bc4964f45e900809827956c0949b36
DIST leatherman-1.12.4.tar.gz 818043 BLAKE2B 7a8718d598bf48b70d555d2a21e2e930eba6b3407ad5414b43d30411acf4c9bf4193ad20058b63d3c8911b7c5b0d021f84d6eca6dd3d00165c7d145186f8177f SHA512 b2645a5049856f93c30bb89e87e3a47cf8137aeac73708248b2b228874818063fb31440ca2bd760783e8c95e880fe7ae34a387fcc448efee01dd0cda48089b55
diff --git a/dev-libs/leatherman/leatherman-1.12.3.ebuild b/dev-libs/leatherman/leatherman-1.12.3.ebuild
deleted file mode 100644
index c7ed781d77ee..000000000000
--- a/dev-libs/leatherman/leatherman-1.12.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils multilib
-
-DESCRIPTION="A C++ toolkit"
-HOMEPAGE="https://github.com/puppetlabs/leatherman"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-IUSE="debug static-libs test"
-#RESTRICT="!test? ( test )"
-RESTRICT="test" # restricted til we don't need the shared_nowide patch
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
-SLOT="0/${PV}"
-
-RDEPEND="net-misc/curl"
-DEPEND=">=dev-libs/boost-1.73:=[nls]
- net-misc/curl
- >=sys-devel/gcc-4.8:*"
-
-PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
-PATCHES+=( "${FILESDIR}"/1.12.2-shared_nowide.patch )
-
-src_prepare() {
- sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
- # vendored boost lib conflicts with boost 1.73 and above
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- )
- if ! use static-libs; then
- mycmakeargs+=(
- -DLEATHERMAN_SHARED=ON
- )
- else
- mycmakeargs+=(
- -DLEATHERMAN_SHARED=OFF
- )
- fi
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
- cmake-utils_src_configure
-}
-
-src_test() {
- "${WORKDIR}/${P}"_build/bin/leatherman_test
-}
-
-src_install() {
- cmake-utils_src_install
-}
diff --git a/dev-libs/leatherman/leatherman-1.12.4.ebuild b/dev-libs/leatherman/leatherman-1.12.4.ebuild
index 75314013d9e0..75654f08f0ec 100644
--- a/dev-libs/leatherman/leatherman-1.12.4.ebuild
+++ b/dev-libs/leatherman/leatherman-1.12.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ LICENSE="Apache-2.0"
IUSE="debug static-libs test"
#RESTRICT="!test? ( test )"
RESTRICT="test" # restricted til we don't need the shared_nowide patch
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
SLOT="0/${PV}"
RDEPEND="net-misc/curl"