summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-01 19:41:38 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-01 19:41:38 +0100
commit69663e78203244605a7cc78435ca20c496e9a108 (patch)
treea093348da13cb693e5ec180c774ef8d2c1a6f781
parentdev-cpp/libbinio: Remove old (diff)
downloadgentoo-69663e78.tar.gz
gentoo-69663e78.tar.bz2
gentoo-69663e78.zip
dev-cpp/libassa: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-cpp/libassa/libassa-3.5.1-r2.ebuild (renamed from dev-cpp/libassa/libassa-3.5.1-r1.ebuild)18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-cpp/libassa/libassa-3.5.1-r1.ebuild b/dev-cpp/libassa/libassa-3.5.1-r2.ebuild
index 81f5fb6d146a..8d46aa4035ef 100644
--- a/dev-cpp/libassa/libassa-3.5.1-r1.ebuild
+++ b/dev-cpp/libassa/libassa-3.5.1-r2.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils
+EAPI=6
DESCRIPTION="A networking library based on Adaptive Communication Patterns"
HOMEPAGE="http://libassa.sourceforge.net/"
@@ -17,12 +16,10 @@ RDEPEND="net-libs/libtirpc"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.5.0-fix-tests.patch \
- "${FILESDIR}"/${P}-gcc47.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.0-fix-tests.patch
+ "${FILESDIR}"/${PN}-3.5.1-gcc47.patch
+)
src_configure() {
econf \
@@ -32,5 +29,6 @@ src_configure() {
src_install() {
default
- find "${ED}" -name "*.la" -exec rm -rf {} + || die "failed to delete .la files"
+
+ find "${D}" -name '*.la' -delete || die
}