summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-29 22:34:11 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-29 22:34:11 +0000
commit696b0f38fdf1d65f8cf9c43dde14243eafb3f797 (patch)
tree9e43220477b9811518de4fe0cb3b3261f0f33957
parentsys-apps/most: Keyword for ppc64. (diff)
downloadgentoo-696b0f38.tar.gz
gentoo-696b0f38.tar.bz2
gentoo-696b0f38.zip
app-shells/localshell: EAPI 5 bump.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-shells/localshell/localshell-1.3.4-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-shells/localshell/localshell-1.3.4-r1.ebuild b/app-shells/localshell/localshell-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..d2b134fc12d0
--- /dev/null
+++ b/app-shells/localshell/localshell-1.3.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Localshell allows per-user/group local control of shell execution"
+HOMEPAGE="http://git.orbis-terrarum.net/?p=infrastructure/localshellc.git;a=summary"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_configure() {
+ # this is a shell, it needs to be in /bin
+ econf --bindir=/bin --sysconfdir=/etc
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+}
+
+pkg_postinst() {
+ elog "Remember to add /bin/localshell to /etc/shells and create"
+ elog "/etc/localshell.conf based on the included configuration examples"
+}