summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-06-10 23:45:03 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-06-10 23:52:02 +0200
commit6974e6a72a3b7210186c377a217ddadf05651129 (patch)
treea306653e376cd179cbe3f1efb083dd26d8315590
parentapp-emulation/free42: add 3.0.11a (diff)
downloadgentoo-6974e6a7.tar.gz
gentoo-6974e6a7.tar.bz2
gentoo-6974e6a7.zip
app-emulation/plus42: add 1.0.6
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--app-emulation/plus42/Manifest1
-rw-r--r--app-emulation/plus42/plus42-1.0.6.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/plus42/Manifest b/app-emulation/plus42/Manifest
index 2cd97749f5d4..f522f663e83d 100644
--- a/app-emulation/plus42/Manifest
+++ b/app-emulation/plus42/Manifest
@@ -1 +1,2 @@
DIST plus42-upstream-1.0.4.tgz 7583399 BLAKE2B 801c125e8b320a2ae2220595aa6244451f55938db644beb5e619c7789b506ada86b4f22e62c724af19da1240aa6c0fad791e2d6176eb4787435f16c1a44aaccc SHA512 a9c23b582047767fe0c57f35fdb4dfb72d7fdf480106a64f1d1151541c5d08e8a1a973156b0e2e5e9ca2f4f74acfbde2a1d69590c02f480d52dec20981be6c6e
+DIST plus42-upstream-1.0.6.tgz 7583604 BLAKE2B 3cfdf41ee3ba627cfe5191cf9c0e452917b8511931206fd46df8516a225c7e0e447d8410348d9ab324269a3182dd9c4708ac881f46ae5058fdd4784acec82e2d SHA512 9f4573de916ba20fae4400f50cbf64b9bfbc452b4b51e4c674cffd5129cac9c9828eee33ab613abed6d94c5863797c17e3bd78b0df50bbaa8e0f9594450713ab
diff --git a/app-emulation/plus42/plus42-1.0.6.ebuild b/app-emulation/plus42/plus42-1.0.6.ebuild
new file mode 100644
index 000000000000..8239110a87e8
--- /dev/null
+++ b/app-emulation/plus42/plus42-1.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PN}-upstream-${PV}"
+
+DESCRIPTION="An Enhanced HP-42S Calculator Simulator"
+HOMEPAGE="https://thomasokken.com/plus42/"
+SRC_URI="https://thomasokken.com/plus42/upstream/${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( CREDITS HISTORY README )
+S="${WORKDIR}/${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.4-fix-makefile.patch"
+ "${FILESDIR}/${PN}-1.0.4-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
+ emake -C gtk clean
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
+}
+
+src_install() {
+ default
+ dobin gtk/plus42bin gtk/plus42dec
+}