summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-29 17:54:02 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-29 17:54:02 +0200
commit6977ecfa3c3b088693630ac3577d574e54811f0b (patch)
tree6b2565cbe05e5cc0a3b845214f893b1f944dda89
parentdev-ruby/rbnacl: drop 7.1.1 (diff)
downloadgentoo-6977ecfa3c3b088693630ac3577d574e54811f0b.tar.gz
gentoo-6977ecfa3c3b088693630ac3577d574e54811f0b.tar.bz2
gentoo-6977ecfa3c3b088693630ac3577d574e54811f0b.zip
dev-ruby/rantly: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rantly/rantly-2.0.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rantly/rantly-2.0.0-r1.ebuild b/dev-ruby/rantly/rantly-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..2e5c1c5be21a
--- /dev/null
+++ b/dev-ruby/rantly/rantly-2.0.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Imperative Random Data Generator and Quickcheck"
+HOMEPAGE="https://github.com/rantly-rb/rantly"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
+}