summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-07 07:59:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-07 09:27:40 +0200
commit6995f54701730815380cfb509053bdca67c62c4c (patch)
treeb8d3ddccc31fa024ce326eb6efe117dae03080c0
parentdev-python/botocore: Bump to 1.18.13 (diff)
downloadgentoo-6995f547.tar.gz
gentoo-6995f547.tar.bz2
gentoo-6995f547.zip
dev-python/boto3: Bump to 1.15.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.15.13.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b054b18ed5f3..867daa3743b1 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,6 +6,7 @@ DIST boto3-1.15.1.tar.gz 335146 BLAKE2B d2d008dcb2059b120f142aaf588264122d1e84b4
DIST boto3-1.15.10.tar.gz 336021 BLAKE2B 71a8bcfd115c0066931e616d1d3678d51ba09460b3c36bf83d838cb0708a7f06afab8b94757a52c055cee51bfbaf1044b086621da16fd6e367cf728aec9080af SHA512 79c12baf5aebb8f2e7048d9713cbb73f2fd100ba8aaabc740757c1bab30e5626fde57b1553ed365dc65b0094513b5a6f305607ce48d62ecd8d5df183ee3db412
DIST boto3-1.15.11.tar.gz 336108 BLAKE2B 9fdc00c194698c047ba7e42dbe8eedd3952fdb65f089deffa1ddb3468102c24b12cd000ed50793dbe2df492e93d12fa697b6541bddda917be80899a65fb2185a SHA512 4fbd08f5479de86aa95463c4d8c23e7d5a3af05effa752214968b9ea9ea652ce74b727206140eac46bc096f5e013a99223ce0820972872b24fcb447a6c28a806
DIST boto3-1.15.12.tar.gz 336150 BLAKE2B c6817e39fb19cd40f7cdcf6140303bd1993ec115e4ed9d0379d3fb05d31115abb964df86d5532cf3325a313957006565718945c2b07fb482d241e45a61659134 SHA512 a12cbfdd7664263ce1a2cba40d13b8a1b82fda9acf113c547e660adba46c31f382cce018ebc47686d5c65763ba5507757504ef00a4c5f2f12d3ff161b5badb14
+DIST boto3-1.15.13.tar.gz 336233 BLAKE2B d82c38c4021c4f76ba5aa37c2b6328cd4870c3d64b343d2ccf4d441c231243ff369d91ec56b45380ca19b1b35a3934c548bca41a61832a7ca519e4119911c383 SHA512 5e50a212f1b47c79e75d3f2dc6ace0984c82041c11a8c87c831cf3ed2452234089b3f91be05af5342893ae377ad3e119e5e2b5f329cf200a877a46f418b55cc1
DIST boto3-1.15.2.tar.gz 335231 BLAKE2B f1eb144da7afc1cf630cdc1f61880d094186a37d46556ae361da278fd3045a119dcb09c3d08387a019ca88d6502fa8710a5e5733cd9dc9056676ef17853d76e2 SHA512 6866e0d6a50d11495e5f2a33a392b0edbe1ff6625235b26b5d6028f7c2c7089d78febe17b982f65dc2564254800a23409247ac09716b099f09f3751c5b7f47b5
DIST boto3-1.15.3.tar.gz 335286 BLAKE2B 05c9ef757b8d227ae06a22e78d978821ff50da719f122ac025940b2e1ac5728d6bac044d4bfab95c56ac8c363efd7abfe3de2b3fd65d423ab53dbdfc60b910da SHA512 dfecfc075896ce84fd58d0437b84a6a794af69ff3e598b35b43f83b2b5ef57b88f96ef62a0d6505d5fe7fef0401513c8ecf0dfcaa22e4575510acd3ece191901
DIST boto3-1.15.4.tar.gz 335401 BLAKE2B 42ee1f2cf1e82338ea59a40b95aa5c76abae51aacf325ae845f407ccbc3caf1b3901bca48036889ad6307f96c257259cce39784a3f52ec6ff03c0c6c5633c654 SHA512 14626faa3943b65a215b8f1bce24f217e69421cdfd40caaf7de0fec13ca9b5b25c5e290c27672b2a6bc41316917224209110e2efd5be817de7273f93ae5764ce
diff --git a/dev-python/boto3/boto3-1.15.13.ebuild b/dev-python/boto3/boto3-1.15.13.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.15.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}