summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-03 00:40:48 +0100
committerSam James <sam@gentoo.org>2021-09-03 00:52:16 +0100
commit69a9553ffe7fc202f3176d2479598fd8ecfff140 (patch)
tree1f2f2d68c90bf0be494aa72c303c053e5e3bf317
parentsys-apps/razercfg: [QA] fix IndirectInherits (diff)
downloadgentoo-69a9553ffe7fc202f3176d2479598fd8ecfff140.tar.gz
gentoo-69a9553ffe7fc202f3176d2479598fd8ecfff140.tar.bz2
gentoo-69a9553ffe7fc202f3176d2479598fd8ecfff140.zip
sys-block/buffer: [QA] fix UnusedInherits
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-block/buffer/buffer-1.19-r4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-block/buffer/buffer-1.19-r4.ebuild b/sys-block/buffer/buffer-1.19-r4.ebuild
index b933ee375e56..ed04e96ac0a8 100644
--- a/sys-block/buffer/buffer-1.19-r4.ebuild
+++ b/sys-block/buffer/buffer-1.19-r4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
-DESCRIPTION="a tapedrive tool for speeding up reading from and writing to tape"
+DESCRIPTION="A tapedrive tool for speeding up reading from and writing to tape"
HOMEPAGE="http://www.microwerks.net/~hugo/"
DEBIAN_PR=12
@@ -22,16 +22,17 @@ SRC_URI="
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE=""
src_prepare() {
+ local f
for f in $(<"${WORKDIR}"/debian/patches/series) ; do
p="${WORKDIR}"/debian/patches/${f}.patch
ln -sf "${f}" "${p}" || die
- einfo $p
+ einfo ${p}
eapply -p1 "${p}" || die
done
- cd "${S}"
+
+ cd "${S}" || die
emake clean
eapply_user
}