summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-05-13 17:14:26 +0100
committerJustin Lecher <jlec@gentoo.org>2017-05-13 17:14:26 +0100
commit69b01273253531de9d83902132d9e745a88e94e2 (patch)
treebe38c0c9217231946b3e514f1d072266f33042b5
parentsys-kernel/aufs-sources: Bump to latest genpatches and linux release (diff)
downloadgentoo-69b01273253531de9d83902132d9e745a88e94e2.tar.gz
gentoo-69b01273253531de9d83902132d9e745a88e94e2.tar.bz2
gentoo-69b01273253531de9d83902132d9e745a88e94e2.zip
sci-chemistry/openbabel: Backport Fix for gcc 6/7
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=594154 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-chemistry/openbabel/files/openbabel-2.3.2-gcc-6_and_7-backport.patch13
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild7
2 files changed, 18 insertions, 2 deletions
diff --git a/sci-chemistry/openbabel/files/openbabel-2.3.2-gcc-6_and_7-backport.patch b/sci-chemistry/openbabel/files/openbabel-2.3.2-gcc-6_and_7-backport.patch
new file mode 100644
index 000000000000..e23dc6020ee5
--- /dev/null
+++ b/sci-chemistry/openbabel/files/openbabel-2.3.2-gcc-6_and_7-backport.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0ee545cf..7f4b944e 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -239,7 +239,7 @@ check_type_size(clock_t CLOCK_T)
+ # Get the GCC version - from KDE4 cmake files
+ if(CMAKE_COMPILER_IS_GNUCXX)
+ exec_program(${CMAKE_C_COMPILER} ARGS --version OUTPUT_VARIABLE _gcc_version_info)
+- string(REGEX MATCH "[345]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
++ string(REGEX MATCH "[34567]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
+ # gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
+ # patch level, handle this here:
+ if (NOT _gcc_version)
diff --git a/sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild b/sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild
index ab9bb5777909..f84e2a1f51b4 100644
--- a/sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild
+++ b/sci-chemistry/openbabel/openbabel-2.3.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -28,7 +28,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README THANKS doc/*.inc doc/README* doc/*.mol2"
-PATCHES=( "${FILESDIR}"/${P}-test_lib_path.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-test_lib_path.patch
+ "${FILESDIR}"/${P}-gcc-6_and_7-backport.patch
+ )
pkg_setup() {
if use openmp; then