summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-25 06:21:38 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-25 06:30:45 -0500
commit69b8dc8c75d61e3f221a11686c6c900bd6348b39 (patch)
treef5a3c8ba5fe2f5ab92af4fe600a87f6a47ee3fa9
parent x11-plugins/pidgin-mbpurple: EAPI8 bump, fix LICENSE (diff)
downloadgentoo-69b8dc8c75d61e3f221a11686c6c900bd6348b39.tar.gz
gentoo-69b8dc8c75d61e3f221a11686c6c900bd6348b39.tar.bz2
gentoo-69b8dc8c75d61e3f221a11686c6c900bd6348b39.zip
dev-libs/simde: new package, add 0.7.6
Needed for x11-terms/kitty-9999 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-libs/simde/Manifest1
-rw-r--r--dev-libs/simde/metadata.xml11
-rw-r--r--dev-libs/simde/simde-0.7.6.ebuild32
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/simde/Manifest b/dev-libs/simde/Manifest
new file mode 100644
index 000000000000..57448efc91a2
--- /dev/null
+++ b/dev-libs/simde/Manifest
@@ -0,0 +1 @@
+DIST simde-0.7.6.tar.gz 6125123 BLAKE2B 96378e81a2e2a2d797289d26b3d0c1ea72288b51094e8c5fde75ecbef34a0c1d4dc029d5974281e2f9f938b190b4a648225fcb486205cc496ba57b1ec528cee4 SHA512 de17fca563c4db6766881e1c73142ad129a57febe55fa8ea1ae780226e60a84891b13d387e75574f2722d77e4013176e3c7dfaf17bccd8682b7d3d3ec8e92a54
diff --git a/dev-libs/simde/metadata.xml b/dev-libs/simde/metadata.xml
new file mode 100644
index 000000000000..f92dc4d96537
--- /dev/null
+++ b/dev-libs/simde/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">simd-everywhere/simde</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/simde/simde-0.7.6.ebuild b/dev-libs/simde/simde-0.7.6.ebuild
new file mode 100644
index 000000000000..42dc44f89526
--- /dev/null
+++ b/dev-libs/simde/simde-0.7.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Header-only library providing implementations of SIMD instruction sets"
+HOMEPAGE="https://simd-everywhere.github.io/blog/"
+SRC_URI="
+ https://github.com/simd-everywhere/simde/archive/refs/tags/v${PV/_/-}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ # *FLAGS are only used for tests (nothing that is installed), and
+ # upstream tests with specific *FLAGS and is otherwise flaky with
+ # -march=native, -mno-*, and such -- unset to be spared headaches.
+ unset {C,CPP,CXX,LD}FLAGS
+
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}