summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-10-29 11:52:34 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-10-29 11:54:38 +0300
commit69c46b51bc046b7d2213a06f145ac11c074562fa (patch)
tree372a912774ec76bf61256b66de262cbd563ea032
parentapp-portage/java-ebuilder: fix typos and missing deps. (diff)
downloadgentoo-69c46b51.tar.gz
gentoo-69c46b51.tar.bz2
gentoo-69c46b51.zip
dev-libs/libp11: ebuild cleanups
fix parallel build issue and manage bindist USE Bug: 598408 Package-Manager: portage-2.3.0
-rw-r--r--dev-libs/libp11/files/libp11-0.4.2-build.patch29
-rw-r--r--dev-libs/libp11/libp11-0.4.2.ebuild15
2 files changed, 41 insertions, 3 deletions
diff --git a/dev-libs/libp11/files/libp11-0.4.2-build.patch b/dev-libs/libp11/files/libp11-0.4.2-build.patch
new file mode 100644
index 000000000000..ebbb38e911cc
--- /dev/null
+++ b/dev-libs/libp11/files/libp11-0.4.2-build.patch
@@ -0,0 +1,29 @@
+From 74b7c656b0a5325c8198ee137bac05878c99d585 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 29 Oct 2016 11:39:29 +0300
+Subject: [PATCH] build: fix symlink installation
+
+this fixes incorrect fix b313f00cc of symlink installation
+by adding dependency instead of overwriting automake behavior.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ src/Makefile.am | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 2aa5195..d0dd37e 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -48,7 +48,7 @@ pkcs11_la_LDFLAGS = $(AM_LDFLAGS) -module -shared -shrext $(SHARED_EXT) \
+ check-local: $(LTLIBRARIES)
+ cd .libs && $(LN_S) -f pkcs11$(SHARED_EXT) libpkcs11$(SHARED_EXT)
+-install-exec-hook:
++install-exec-hook: install-enginesLTLIBRARIES
+ cd '$(DESTDIR)$(enginesdir)' && $(LN_S) -f pkcs11$(SHARED_EXT) libpkcs11$(SHARED_EXT)
+
+ if WIN32
+ # def file required for MS users to build library
+--
+2.7.3
+
diff --git a/dev-libs/libp11/libp11-0.4.2.ebuild b/dev-libs/libp11/libp11-0.4.2.ebuild
index 8a4218a8deb7..2451b3e39ec2 100644
--- a/dev-libs/libp11/libp11-0.4.2.ebuild
+++ b/dev-libs/libp11/libp11-0.4.2.ebuild
@@ -4,7 +4,7 @@
EAPI="6"
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
HOMEPAGE="https://github.com/opensc/libp11/wiki"
@@ -13,15 +13,24 @@ SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="libressl doc static-libs"
+IUSE="libressl bindist doc static-libs"
RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
+ !libressl? ( dev-libs/openssl:0=[bindist] )
libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
--enable-shared \