summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-04 01:56:17 +0000
committerSam James <sam@gentoo.org>2022-11-04 02:22:16 +0000
commit69cddc64a2c8fba7b5023097d4160035b012b4cc (patch)
tree64e352f3d945cef21cca9723d8c0c4e3bdc29889
parentmedia-libs/libde265: add 1.0.9 (diff)
downloadgentoo-69cddc64.tar.gz
gentoo-69cddc64.tar.bz2
gentoo-69cddc64.zip
media-libs/raptor: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/raptor/files/raptor-2.0.15-configure-clang16.patch28
-rw-r--r--media-libs/raptor/raptor-2.0.15-r7.ebuild (renamed from media-libs/raptor/raptor-2.0.15-r6.ebuild)1
2 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/raptor/files/raptor-2.0.15-configure-clang16.patch b/media-libs/raptor/files/raptor-2.0.15-configure-clang16.patch
new file mode 100644
index 000000000000..ab62fd9bff0c
--- /dev/null
+++ b/media-libs/raptor/files/raptor-2.0.15-configure-clang16.patch
@@ -0,0 +1,28 @@
+https://github.com/dajobe/raptor/pull/55
+
+From b7c252e1d5601321a5a6f6627745753b5c704762 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 4 Nov 2022 01:53:32 +0000
+Subject: [PATCH] configure.ac: fix -Wimplicit-function-declaration in
+ HAVE___FUNCTION__ test
+
+This breaks with Clang 16 which makes such errors fatal:
+```
+error: call to undeclared library function 'printf' with type 'int (const char *, ...)'; ISO C99 and later do not support implicit function declarations [-Werror,-Wimplicit-function-declaration]
+error: call to undeclared library function 'printf' with type 'int (const char *, ...)'; ISO C99 and later do not support implicit function declarations [-Werror,-Wimplicit-function-declaration]
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -335,7 +335,8 @@ AC_C_BIGENDIAN
+ AC_C_INLINE
+
+ AC_MSG_CHECKING(whether __FUNCTION__ is available)
+-AC_COMPILE_IFELSE([AC_LANG_SOURCE([int main() { printf(__FUNCTION__); }])],
++AC_COMPILE_IFELSE([AC_LANG_SOURCE([#include <stdio.h>
++int main() { printf(__FUNCTION__); }])],
+ [AC_DEFINE([HAVE___FUNCTION__], [1], [Is __FUNCTION__ available])
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)])
+
diff --git a/media-libs/raptor/raptor-2.0.15-r6.ebuild b/media-libs/raptor/raptor-2.0.15-r7.ebuild
index c13617839b54..6cc547d09459 100644
--- a/media-libs/raptor/raptor-2.0.15-r6.ebuild
+++ b/media-libs/raptor/raptor-2.0.15-r7.ebuild
@@ -47,6 +47,7 @@ PATCHES=(
"${FILESDIR}/${P}-use-pkg-config-icu.patch"
"${FILESDIR}/${P}-use-pkg-config-libxslt.patch"
"${FILESDIR}/${P}-clang-pointer-integer-warning.patch"
+ "${FILESDIR}/${P}-configure-clang16.patch"
)
src_prepare() {