summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 20:50:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 20:50:38 +0100
commit69e8c034460d111b153d07b8cc14620ffc9feb1e (patch)
treec886e4982e5c4166fd0324e757310cbf082dde0b
parentdev-python/django-cors-headers: Bump to 4.3.1 (diff)
downloadgentoo-69e8c034460d111b153d07b8cc14620ffc9feb1e.tar.gz
gentoo-69e8c034460d111b153d07b8cc14620ffc9feb1e.tar.bz2
gentoo-69e8c034460d111b153d07b8cc14620ffc9feb1e.zip
dev-python/google-api-python-client: Bump to 2.108.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.108.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 22804fd4a3f5..4541175d1f4b 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google-api-python-client-2.105.0.tar.gz 12113230 BLAKE2B d2401ca4ee47f7017e5644479644894cf704bbba6fa97fbe225577c3c10afcb374a52444b32fc5ecb2ea5a38d6f7cdb71055c2ef0873e39d277738d33a778873 SHA512 d610579b1fc5be6b47b9add52e1d39ef7f007869e17fb7f6dbdcdd78f01e1d7f8a8de208499f9c718b1ce567b8723a44a6a93ad22b94cebd33c47cf584e03118
DIST google-api-python-client-2.106.0.tar.gz 12128677 BLAKE2B 8bbd135199e0408bb1d614257b5ee31abaa86090fec4ecee16359f0c34421d928e4ff2da3c9c8a08d4b3f1634db61006fe12e0136149a5ff7a232c3b68741704 SHA512 631a26d15eb58186231031093d8c766c06a2dccb822d74d58be7f77de6b2631d90210b67122edaf54f925eadf7c989b06b8e806b1bedc58d46fdfe24af3e4ec4
DIST google-api-python-client-2.107.0.tar.gz 12177116 BLAKE2B 0e19a5f3048b3068a4f90fef93a81dcb875b62aae80957cf68c344b87057efcca369b721bc07c1fc5521fff30511d1666c51f85a593f4c94351e5734abf13bd1 SHA512 5c13c37b733ce9db9f705e9520c99f173936989e546b5e96e12097b59a0436538c7df0aaad1e1f8f7be10e04c4e80a9b70d899cefedecdd6e6642d5d8e8a220f
+DIST google-api-python-client-2.108.0.tar.gz 12227437 BLAKE2B 7b8023f0e940730539bbfed2c213f6ec007b4e838eb87d8c7bd037c5f6dd73cbf97cdb6cec869d10f4c0135ff2989e1fa0b6a4b51cc118e7be2e45e2488d3b76 SHA512 baff038d8161de7150ac877dcca3af8a7f38fc9cfcdae9e70bdaf877f11fa35f572102ec1b6eda47a24f26386638285fc0ff31fbeb185d9174a40ca90cf20ba3
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.108.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.108.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.108.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}