summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-05 21:28:06 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-05 21:29:55 +0100
commit6a04a7a0e844fa890bb24a1c8a4faf29b14a73fd (patch)
tree675da7d1090d794fed11d7b221878b3e61149182
parentnet-analyzer/iptraf-ng: Use Github hosted source tarball (diff)
downloadgentoo-6a04a7a0.tar.gz
gentoo-6a04a7a0.tar.bz2
gentoo-6a04a7a0.zip
net-analyzer/iptraf-ng: Update live ebuild
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/iptraf-ng/iptraf-ng-1.1.4-r3.ebuild3
-rw-r--r--net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild20
2 files changed, 10 insertions, 13 deletions
diff --git a/net-analyzer/iptraf-ng/iptraf-ng-1.1.4-r3.ebuild b/net-analyzer/iptraf-ng/iptraf-ng-1.1.4-r3.ebuild
index 2d069e16ad88..b068ef51aeb0 100644
--- a/net-analyzer/iptraf-ng/iptraf-ng-1.1.4-r3.ebuild
+++ b/net-analyzer/iptraf-ng/iptraf-ng-1.1.4-r3.ebuild
@@ -47,7 +47,7 @@ src_prepare() {
}
src_configure() {
- # configure does not do very much we do not already control
+ # The configure script does not do very much we do not already control
append-cppflags '-DLOCKDIR=\"/run/lock/iptraf-ng\"'
tc-export CC
}
@@ -57,6 +57,7 @@ src_install() {
doman src/*.8
dodoc AUTHORS CHANGES FAQ README* RELEASE-NOTES
+
if use doc; then
docinto html
dodoc -r Documentation/*
diff --git a/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild b/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
index 284d4bb322e4..4c2ce0db62b9 100644
--- a/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
+++ b/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+inherit flag-o-matic git-r3 toolchain-funcs
DESCRIPTION="A console-based network monitoring utility"
HOMEPAGE="https://github.com/iptraf-ng/iptraf-ng"
@@ -13,8 +13,6 @@ SLOT="0"
KEYWORDS=""
IUSE="doc"
-RESTRICT="test"
-
RDEPEND="
>=sys-libs/ncurses-5.7-r7:0=
"
@@ -23,10 +21,9 @@ DEPEND="
virtual/os-headers
!net-analyzer/iptraf
"
+RESTRICT="test"
src_prepare() {
- default
-
sed -i \
-e '/^CC =/d' \
-e '/^CFLAGS/s:= -g -O2:+= :' \
@@ -40,15 +37,14 @@ src_prepare() {
-e 's|rvnamed|&-ng|g' \
-e 's|RVNAMED|&-NG|g' \
src/*.8 || die
-}
-# configure does not do very much we do not already control
-src_configure() { :; }
+ default
+}
-src_compile() {
+src_configure() {
+ # The configure script does not do very much we do not already control
+ append-cppflags '-DLOCKDIR=\"/run/lock/iptraf-ng\"'
tc-export CC
- CFLAGS+=' -DLOCKDIR=\"/run/lock/iptraf-ng\"'
- default
}
src_install() {
@@ -59,7 +55,7 @@ src_install() {
if use doc; then
docinto html
- dodoc -r Documentation
+ dodoc -r Documentation/*
fi
keepdir /var/{lib,log}/iptraf-ng #376157