summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornado <nado@troglodyte.be>2018-07-19 17:57:25 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-03 08:50:07 +0200
commit6a058bfd996599ead9fe3e50f802ccd088bd0a73 (patch)
tree2ece849beec1e09d7771f925fff229345dafb8c5
parentdev-util/cgdb: remove old (0.6.[67]) (diff)
downloadgentoo-6a058bfd.tar.gz
gentoo-6a058bfd.tar.bz2
gentoo-6a058bfd.zip
dev-util/cgdb: run tests in `dtach` + EAPI bump
cgdb needs interactive shell for testing its ncurses UI Closes: https://bugs.gentoo.org/654986 Package-Manager: Portage-2.3.43, Repoman-2.3.10 Signed-off-by: Corentin `nado` Pazdera <nado@troglodyte.be> Closes: https://github.com/gentoo/gentoo/pull/9288 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/cgdb/cgdb-0.7.0-r1.ebuild (renamed from dev-util/cgdb/cgdb-0.7.0.ebuild)31
-rw-r--r--dev-util/cgdb/cgdb-9999.ebuild33
2 files changed, 51 insertions, 13 deletions
diff --git a/dev-util/cgdb/cgdb-0.7.0.ebuild b/dev-util/cgdb/cgdb-0.7.0-r1.ebuild
index f1e40470f225..b4fe338de7f7 100644
--- a/dev-util/cgdb/cgdb-0.7.0.ebuild
+++ b/dev-util/cgdb/cgdb-0.7.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
inherit git-r3
@@ -20,15 +20,18 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="test"
-COMMONDEPEND="
+DEPEND="
sys-libs/ncurses:0=
sys-libs/readline:0="
-DEPEND="${COMMONDEPEND}
- test? ( dev-util/dejagnu )"
+BDEPEND="
+ test? (
+ dev-util/dejagnu
+ app-misc/dtach
+ )"
RDEPEND="
- ${COMMONDEPEND}
+ ${DEPEND}
sys-devel/gdb"
DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
@@ -38,6 +41,22 @@ src_prepare() {
./autogen.sh || die
}
+multilib_src_test() {
+ # Tests need an interactive shell, #654986
+
+ # real-time output of the log ;-)
+ touch "${T}/dtach-test.log" || die
+ tail -f "${T}/dtach-test.log" &
+ local tail_pid=${!}
+
+ nonfatal dtach -N "${T}/dtach.sock" \
+ bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
+
+ kill "${tail_pid}"
+ [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
+ [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" econf
}
diff --git a/dev-util/cgdb/cgdb-9999.ebuild b/dev-util/cgdb/cgdb-9999.ebuild
index 5a5dd25473fd..b4fe338de7f7 100644
--- a/dev-util/cgdb/cgdb-9999.ebuild
+++ b/dev-util/cgdb/cgdb-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
inherit git-r3
@@ -20,24 +20,43 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="test"
-COMMONDEPEND="
+DEPEND="
sys-libs/ncurses:0=
sys-libs/readline:0="
-DEPEND="${COMMONDEPEND}
- test? ( dev-util/dejagnu )"
+BDEPEND="
+ test? (
+ dev-util/dejagnu
+ app-misc/dtach
+ )"
RDEPEND="
- ${COMMONDEPEND}
+ ${DEPEND}
sys-devel/gdb"
-DOCS=( AUTHORS ChangeLog INSTALL NEWS README.md FAQ )
+DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
src_prepare() {
default
./autogen.sh || die
}
+multilib_src_test() {
+ # Tests need an interactive shell, #654986
+
+ # real-time output of the log ;-)
+ touch "${T}/dtach-test.log" || die
+ tail -f "${T}/dtach-test.log" &
+ local tail_pid=${!}
+
+ nonfatal dtach -N "${T}/dtach.sock" \
+ bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
+
+ kill "${tail_pid}"
+ [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
+ [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" econf
}