summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 12:12:39 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 12:43:01 +0200
commit6a1950fb1d9251aa59c179a78ed88e6d78e0bbfc (patch)
treea46c3e3349aaf2b70e5fcac13b458b5108a03c32
parentapp-text/libgxps: Drop old (diff)
downloadgentoo-6a1950fb.tar.gz
gentoo-6a1950fb.tar.bz2
gentoo-6a1950fb.zip
app-text/libgxps: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--app-text/libgxps/Manifest1
-rw-r--r--app-text/libgxps/libgxps-0.2.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/libgxps/Manifest b/app-text/libgxps/Manifest
index a0bf7dd27eb4..c6fcf517b904 100644
--- a/app-text/libgxps/Manifest
+++ b/app-text/libgxps/Manifest
@@ -1 +1,2 @@
DIST libgxps-0.2.3.2.tar.xz 323060 SHA256 6ea5f0ed85665a4e6702e31e38b5f1b2e5ae4f3d316a55d7f1fb1799224b4127 SHA512 fc1f8f1a3091efaa60f29a1842e997ed72c9888b8d903b613dd0073468172a8e2d757877207ab81b155fcb3988ec975c91490c20afb4ebae1e03e0e1cc620257 WHIRLPOOL d5069483f105ae1f4e4435c5b2fce18d7175a82354d59f311a0b8582d88a13695886870ef63772d7573dbaa1fdb3c1d68c2e975437d73ec4d24b2281033af399
+DIST libgxps-0.2.4.tar.xz 335256 SHA256 e9d6aa02836d9d4823a51705d3e1dee6fc4bce11d72566024042cfaac56ec7a4 SHA512 3e2821931a63483281952d9818dc77295caa8a514d0a25deffd922d98a9db8ced4141cc8489781715a021af361a2e41210aad1fb773f94dff0f864f8e45d2681 WHIRLPOOL 57a7f460e5cfc449b5ca95cd2e8d658d8857b4618cf79896a5da05fbd24e5c38092392f39ef5c96e20b30e1267317ef6e9c3bfd9eada105117bd29a53dd86ebf
diff --git a/app-text/libgxps/libgxps-0.2.4.ebuild b/app-text/libgxps/libgxps-0.2.4.ebuild
new file mode 100644
index 000000000000..697cf562aab9
--- /dev/null
+++ b/app-text/libgxps/libgxps-0.2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Library for handling and rendering XPS documents"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgxps"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug +introspection jpeg lcms static-libs tiff"
+
+RDEPEND="
+ >=app-arch/libarchive-2.8
+ >=dev-libs/glib-2.24:2
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=x11-libs/cairo-1.10[svg]
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1:= )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ tiff? ( media-libs/tiff:0[zlib] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+# There is no automatic test suite, only an interactive test application
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-man \
+ --disable-test \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_with jpeg libjpeg) \
+ $(use_with lcms liblcms2) \
+ $(use_enable static-libs static) \
+ $(use_with tiff libtiff)
+}