summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 12:50:13 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 12:50:13 +0100
commit6a1d76b6138e6a7150e8d6228b6d43e9be997158 (patch)
treeb0635e50c50435e3b14e82aaa98e7bb6c44d8651
parentapp-misc/vifm: Bump to 0.11 (diff)
downloadgentoo-6a1d76b6.tar.gz
gentoo-6a1d76b6.tar.bz2
gentoo-6a1d76b6.zip
app-text/barcode: Port to EAPI 7
Closes: https://bugs.gentoo.org/707686 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-text/barcode/barcode-0.99.ebuild13
-rw-r--r--app-text/barcode/files/0.98-info.patch14
-rw-r--r--app-text/barcode/files/barcode-0.99-fno-common.patch25
3 files changed, 29 insertions, 23 deletions
diff --git a/app-text/barcode/barcode-0.99.ebuild b/app-text/barcode/barcode-0.99.ebuild
index ce0692e849f4..bd58bc146e16 100644
--- a/app-text/barcode/barcode-0.99.ebuild
+++ b/app-text/barcode/barcode-0.99.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit eutils multilib
+EAPI=7
DESCRIPTION="barcode generator"
HOMEPAGE="https://www.gnu.org/software/barcode/"
@@ -12,10 +10,12 @@ SRC_URI="mirror://gnu/barcode/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+
RDEPEND="app-text/libpaper"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_prepare() {
sed -i -e '/^LDFLAGS =/s:=:+=:' \
-e "/^aLIBDIR/s:lib:$(get_libdir):" \
@@ -25,8 +25,3 @@ src_prepare() {
default
}
-
-src_install() {
- default
- dodoc ChangeLog README TODO
-}
diff --git a/app-text/barcode/files/0.98-info.patch b/app-text/barcode/files/0.98-info.patch
deleted file mode 100644
index 740458f88ed4..000000000000
--- a/app-text/barcode/files/0.98-info.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- doc/barcode.info.old 2003-10-26 19:08:39.000000000 -0800
-+++ doc/barcode.info 2003-10-26 19:58:42.179447512 -0800
-@@ -1,6 +1,11 @@
- This is barcode.info, produced by makeinfo version 4.0 from
- barcode.texinfo.
-
-+INFO-DIR-SECTION Miscellaneous
-+START-INFO-DIR-ENTRY
-+* Barcode: (barcode). Barcode generation library.
-+END-INFO-DIR-ENTRY
-+
- This file is the User's Manual for the barcode library (version
- 0.98).
-
diff --git a/app-text/barcode/files/barcode-0.99-fno-common.patch b/app-text/barcode/files/barcode-0.99-fno-common.patch
new file mode 100644
index 000000000000..5abb8a26824f
--- /dev/null
+++ b/app-text/barcode/files/barcode-0.99-fno-common.patch
@@ -0,0 +1,25 @@
+Taken from: https://sources.debian.org/patches/barcode/0.99-4/0006-Fix-FTBFS-with-gcc-10.patch/
+Author: https://sources.debian.org/patches/barcode/0.99-4/0006-Fix-FTBFS-with-gcc-10.patch/
+--- a/barcode.h
++++ b/barcode.h
+@@ -123,6 +123,6 @@ extern int Barcode_Version(char *versionname);
+ }
+ #endif
+
+-int streaming;
++extern int streaming;
+
+ #endif /* _BARCODE_H_ */
+diff --git a/library.c b/library.c
+index 30946ff..5390a2b 100644
+--- a/library.c
++++ b/library.c
+@@ -30,6 +30,8 @@
+ #endif
+ #include <errno.h>
+
++int streaming;
++
+ /*
+ * This function allocates a barcode structure and strdup()s the
+ * text string. It returns NULL in case of error