summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-25 11:53:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-25 16:42:41 +0200
commit6a25d382e1778e66da3998065d15f4c096769b6c (patch)
tree58114813d177546882b7b9e73497c26f6d02ef4b
parentdev-ml/ppx_inline_test: add missing dev-ml/ppx_traverse_builtins:= dep (diff)
downloadgentoo-6a25d382e1778e66da3998065d15f4c096769b6c.tar.gz
gentoo-6a25d382e1778e66da3998065d15f4c096769b6c.tar.bz2
gentoo-6a25d382e1778e66da3998065d15f4c096769b6c.zip
dev-ml/mtime: bump to 1.1.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ml/mtime/Manifest1
-rw-r--r--dev-ml/mtime/mtime-1.1.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/mtime/Manifest b/dev-ml/mtime/Manifest
index 08b14c1e208d..05540723e56a 100644
--- a/dev-ml/mtime/Manifest
+++ b/dev-ml/mtime/Manifest
@@ -1,2 +1,3 @@
DIST mtime-0.8.4.tbz 11705 SHA256 b0a1eb1fb2d30e413ab24f5261e099881cadbac5af440f53f2544e3a9846b5a9 SHA512 fc08df2abc3500d18db3c4bb9a67336b902483da24056fac2c9f0b4c93ac8860c29a59b47c1ade62f6f5b51ac32c7d16e31d5c9f8cb51900accf73ddeaf6d307 WHIRLPOOL 543168a929e4eaf158cd05420f9139664a4289c5ae1e69bf9081f842d97b08182c99dc3ac82b242afca4067f69b1efc53fb11c116056162871f59b988be2a8d5
DIST mtime-1.0.0.tbz 15191 SHA256 dd9e2eaaa2e275e832d9acf3c84654eb02e74d449705f7d46739e2bac77657ac SHA512 8fb7c125e65f2edcfef937794138e3fa468805f7c728eb2dc8e071a9080dcb72952493b71f99ad8f04de52b491c9b84fd37924b9ec36c70ebe717e6e99b29c2b WHIRLPOOL 648dc5a833493dbd71756eaa4211255bc4f7617ead78047cfdb41990b9d21dd1d33dc1c46cabf5d51c40b7959f35647a9a8e737d3fe6669476d1303131b89d73
+DIST mtime-1.1.0.tbz 15467 SHA256 63362f4a8ffd9a86e3f107d57f7cbd4cf829b339fa2498177a83e51cb9a464e1 SHA512 8ed5dae589dd27fc6e748218a9d9fb9d7d954d231fc2100d61c1b336e0ed38a215bc608cdea9965547729177c78c868c1de6a5ceac6735686a3de1c4a791746c WHIRLPOOL 19644c0290ec97752501b8f527b7a53d5dfb59fbbf47fd43b3072d915e797ca7732ed635c6b8906d06bc527517f7be72e388914a01bd8dab6b22c51e0f277374
diff --git a/dev-ml/mtime/mtime-1.1.0.ebuild b/dev-ml/mtime/mtime-1.1.0.ebuild
new file mode 100644
index 000000000000..02c8e3c21559
--- /dev/null
+++ b/dev-ml/mtime/mtime-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="OCaml module to access monotonic wall-clock time"
+HOMEPAGE="http://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
+SRC_URI="http://erratique.ch/software/mtime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="javascript test"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]
+ javascript? ( dev-ml/js_of_ocaml:= )
+"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-js_of_ocaml $(usex javascript true false) \
+ --tests $(usex test true false) \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md README.md
+}