summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-04-05 22:28:46 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-04-05 22:33:06 +0100
commit6a476961b04ddee6c2ae97485e8c0d0c87ef4cea (patch)
tree7af922301d519251903627bb948db111569d261c
parentdev-db/influxdb: fix LICENSE (diff)
downloadgentoo-6a476961b04ddee6c2ae97485e8c0d0c87ef4cea.tar.gz
gentoo-6a476961b04ddee6c2ae97485e8c0d0c87ef4cea.tar.bz2
gentoo-6a476961b04ddee6c2ae97485e8c0d0c87ef4cea.zip
media-libs/libsdl2: Rename gles USE flag to gles2
We unconditionally disable GLES1 support. Kodi is the only package still using the "gles" flag now. Closes: https://bugs.gentoo.org/716248 Package-Manager: Portage-2.3.96, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.12-r1.ebuild (renamed from media-libs/libsdl2/libsdl2-2.0.12.ebuild)10
-rw-r--r--media-libs/libsdl2/metadata.xml3
2 files changed, 7 insertions, 6 deletions
diff --git a/media-libs/libsdl2/libsdl2-2.0.12.ebuild b/media-libs/libsdl2/libsdl2-2.0.12-r1.ebuild
index e8daba276a72..cae1b46a7eb3 100644
--- a/media-libs/libsdl2/libsdl2-2.0.12.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.12-r1.ebuild
@@ -13,23 +13,23 @@ LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus gles haptic jack +joystick kms libsamplerate nas opengl oss pulseaudio +sound static-libs +threads tslib udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
+IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus gles2 haptic jack +joystick kms libsamplerate nas opengl oss pulseaudio +sound static-libs +threads tslib udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
REQUIRED_USE="
alsa? ( sound )
- gles? ( video )
+ gles2? ( video )
jack? ( sound )
nas? ( sound )
opengl? ( video )
pulseaudio? ( sound )
vulkan? ( video )
- wayland? ( gles )
+ wayland? ( gles2 )
xinerama? ( X )
xscreensaver? ( X )"
CDEPEND="
alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
- gles? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ gles2? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
jack? ( virtual/jack[${MULTILIB_USEDEP}] )
kms? (
>=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
@@ -161,7 +161,7 @@ multilib_src_configure() {
$(use_enable video video-dummy)
$(use_enable opengl video-opengl)
--disable-video-opengles1
- $(use_enable gles video-opengles2)
+ $(use_enable gles2 video-opengles2)
$(use_enable vulkan video-vulkan)
$(use_enable udev libudev)
$(use_enable dbus)
diff --git a/media-libs/libsdl2/metadata.xml b/media-libs/libsdl2/metadata.xml
index 253e9af8f2d9..37b2b8577235 100644
--- a/media-libs/libsdl2/metadata.xml
+++ b/media-libs/libsdl2/metadata.xml
@@ -24,7 +24,8 @@
Perl, PHP, Pike, Python, and Ruby.
</longdescription>
<use>
- <flag name="gles">include OpenGL ES support</flag>
+ <flag name="gles">include OpenGL ES 2.0 support</flag>
+ <flag name="gles2">include OpenGL ES 2.0 support</flag>
<flag name="haptic">Enable the haptic (force feedback) subsystem</flag>
<flag name="joystick">Control joystick support (disable at your own risk)</flag>
<flag name="kms">Build the KMSDRM video driver</flag>