summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-09-28 00:15:49 +0100
committerYixun Lan <dlan@gentoo.org>2023-10-17 05:23:41 +0000
commit6a6065cec56d95c775da3d4503e2114747ee9966 (patch)
treedb685c14024e07eb2280af970a382ebd778e4fdd
parentdev-games/recastnavigation: drop 1.5.1_p20230102 (diff)
downloadgentoo-6a6065cec56d95c775da3d4503e2114747ee9966.tar.gz
gentoo-6a6065cec56d95c775da3d4503e2114747ee9966.tar.bz2
gentoo-6a6065cec56d95c775da3d4503e2114747ee9966.zip
games-arcade/open-supaplex: update EAPI 7 -> 8
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--games-arcade/open-supaplex/open-supaplex-7.1.2-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-arcade/open-supaplex/open-supaplex-7.1.2-r1.ebuild b/games-arcade/open-supaplex/open-supaplex-7.1.2-r1.ebuild
new file mode 100644
index 000000000000..0235c790c240
--- /dev/null
+++ b/games-arcade/open-supaplex/open-supaplex-7.1.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic toolchain-funcs
+
+DESCRIPTION="OSS reimplementation of Supaplex in C and SDL"
+HOMEPAGE="https://github.com/sergiou87/open-supaplex"
+SRC_URI="https://github.com/sergiou87/open-supaplex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/sdl2-mixer[vorbis]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-lang/ruby )
+"
+
+src_prepare() {
+ default
+ rm -r resources/audio-{l,m}q || die
+}
+
+src_compile() {
+ append-cflags -DFILE_FHS_XDG_DIRS -DFILE_DATA_PATH="${EPREFIX}/usr/share/OpenSupaplex"
+ emake -C linux CC="$(tc-getCC)"
+}
+
+src_test() {
+ emake -C tests CC="$(tc-getCC)"
+ # Avoid installing savegames, configs, etc, if any were written during the test
+ cp -R resources "${T}/test" || die
+ cd tests || die
+ # gems are not used by the test, but by default ruby fails to start if
+ # dev-ruby/rubygems is not installed. dev-lang/ruby depends on that package
+ # via PDEPEND which is why it's not available if ruby was pulled as a
+ # dependency to open-supaplex on clean machine.
+ # https://bugs.gentoo.org/739126
+ OPENSUPAPLEX_PATH="${T}/test" ruby --disable=gems ./run-tests.rb ./opensupaplex || die
+}
+
+src_install() {
+ dobin linux/opensupaplex
+ insinto /usr/share/OpenSupaplex
+ doins -r resources/*
+ doicon "${FILESDIR}/open-supaplex.svg"
+ make_desktop_entry opensupaplex OpenSupaplex open-supaplex
+}