summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-03 12:37:18 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-03 13:41:11 +0200
commit6a60a60bc411370eaf9290f88e9827d340eb01ea (patch)
tree3b9c54b0470f2cb0949ab6cf7d82f12799fd1827
parentnet-libs/gssdp: Version bump (diff)
downloadgentoo-6a60a60bc411370eaf9290f88e9827d340eb01ea.tar.gz
gentoo-6a60a60bc411370eaf9290f88e9827d340eb01ea.tar.bz2
gentoo-6a60a60bc411370eaf9290f88e9827d340eb01ea.zip
net-libs/gupnp: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--net-libs/gupnp/Manifest1
-rw-r--r--net-libs/gupnp/gupnp-0.20.18.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-libs/gupnp/Manifest b/net-libs/gupnp/Manifest
index 9f0b44422473..54b756d33ac8 100644
--- a/net-libs/gupnp/Manifest
+++ b/net-libs/gupnp/Manifest
@@ -1,2 +1,3 @@
DIST gupnp-0.20.16.tar.xz 406912 SHA256 ff1119eff12529c46837e03c742f69dc4fae48d59097d79582d38a383b832602 SHA512 3db3b72a4e5eed6c7910eba4f27e7acacc21d4b4c63488dc3a0328a7a8ab4082fad203bd67923fc35cb6475a4bc918ca95cb50a6eb6ac8e1c6e88e969d9549f7 WHIRLPOOL 1f46ed6dd5725720ce6c6617d712552ec7dac05f0e75e5cf7d3d99a82299427cacb1d4b807e6149a3b9b7ea489233cf7cb299528108b80b3c8ff0210533d27e0
DIST gupnp-0.20.17.tar.xz 409184 SHA256 c9e415db749e75d82b17de341e6430ebce2a7ce457640c039cfcb03b498a8fd2 SHA512 2f78036a09db2e8aacab4cf34851c26cd350343efaf294a032ec348561186e6805457fc6ea5f79bf438cf44331d997a0e154edd1bce30d6712974f170cad676c WHIRLPOOL 8c55f1a692847a8f6d92d1eb99fb628856e6663c11cb675f7b3c2c2a2c3f4f8b031796c4368c9d8aada5c4056be59e33ff04aa66297d368bc549ce26b871065e
+DIST gupnp-0.20.18.tar.xz 409712 SHA256 c5e0e11061f8d0ff9c8dccc196f39c45a49c0153c9a72abf6290ab34d1cbb021 SHA512 553e2b55434f6a8e084c656d30017b671842a06ad1c6b8b0739f9f81693d3d18061e2e5b3294f247b11b2b95368ad00c89e13d3db5fc04a3b3549593c7f73a5f WHIRLPOOL 2b594f39d5deae1ef393a503752e969a213e295ac9f83f0721d0193168624a39b58bdedbfe12ffd6c2db2e7ea54a8eb38dfa6c5349d9692db07d5295754f741f
diff --git a/net-libs/gupnp/gupnp-0.20.18.ebuild b/net-libs/gupnp/gupnp-0.20.18.ebuild
new file mode 100644
index 000000000000..0575ae3705d8
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.20.18.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+# FIXME: Claims to works with python3 but appears to be wishful thinking
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 multilib-minimal python-r1 vala
+
+DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="connman +introspection kernel_linux networkmanager"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( connman networkmanager )
+"
+
+# prefix: uuid dependency can be adapted to non-linux platforms
+RDEPEND="${PYTHON_DEPS}
+ >=net-libs/gssdp-0.14.15:0=[introspection?,${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.48.0:2.4[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ introspection? (
+ >=dev-libs/gobject-introspection-1.36:=
+ $(vala_depend) )
+ connman? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ networkmanager? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local backend=unix
+ use kernel_linux && backend=linux
+ use connman && backend=connman
+ use networkmanager && backend=network-manager
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ --disable-static \
+ --with-context-manager=${backend}
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ python_foreach_impl python_doscript tools/gupnp-binding-tool
+}