summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-04-28 01:17:44 +1100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-04-28 01:17:44 +1100
commit6a7dea8c163832c1a7c8da20fb97e91cb1fef144 (patch)
tree9456ba68032143c2247651b63f7c0ff9063d51fe
parentsci-libs/linux-gpib-modules: drop 4.3.5 (diff)
downloadgentoo-6a7dea8c163832c1a7c8da20fb97e91cb1fef144.tar.gz
gentoo-6a7dea8c163832c1a7c8da20fb97e91cb1fef144.tar.bz2
gentoo-6a7dea8c163832c1a7c8da20fb97e91cb1fef144.zip
sci-libs/linux-gpib: add 4.3.6
Bug: https://bugs.gentoo.org/916686 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--sci-libs/linux-gpib/Manifest1
-rw-r--r--sci-libs/linux-gpib/linux-gpib-4.3.6.ebuild184
2 files changed, 185 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib/Manifest b/sci-libs/linux-gpib/Manifest
index 03b2905a5e32..2fa47a31d5ad 100644
--- a/sci-libs/linux-gpib/Manifest
+++ b/sci-libs/linux-gpib/Manifest
@@ -1,2 +1,3 @@
DIST gpib_firmware-2008-08-10.tar.gz 173004 BLAKE2B 05fcde09de5246b86004c263c733d64316511bdb0b84dfbd9b94cb78e2909c0d191ff21ee0d77e7f0947e9231bd4cd62d6348e8f9beefd6d201b473732ff23d2 SHA512 f2a0ee3316b75ac36ed88568e45ca4c69935a6d10783c65582003ab39686f2a69d3002901866065f4f5efa9fdd4c779e038d1d7ce24bba266a619c164d5ac10d
DIST linux-gpib-4.3.5.tar.gz 1462624 BLAKE2B fff30ed1a7abc18cd4317e8f8979ef4014a532baab8c014f9a2eaa3338a2e8e8b672214d3f2b3f44066be15f432861a3fe3d67652f6966e73e561d99ff1e1566 SHA512 018cc255922a6335f8d28418b0a0808c3a369506470d9c81432ac7183ae255217d938a419e10ba2b0c44205a9d901405ce00ad5bdd968db2721cedd83baa2f76
+DIST linux-gpib-4.3.6.tar.gz 1433121 BLAKE2B 64e2b19106d0531df990b1338f82a71707e54f448d652f6379eb9cd71feb84637090ed8fdfb0264248aa6879d5b9a1dc50e75c21a2c22a31397120eea5903e98 SHA512 a8005c71bfddb854ecbe4df0a81530e44378150242508b10df58c61d039c6d329020407608e31f1ef360de0c83169e76b793c032256e732d229bfd2da4cbaa35
diff --git a/sci-libs/linux-gpib/linux-gpib-4.3.6.ebuild b/sci-libs/linux-gpib/linux-gpib-4.3.6.ebuild
new file mode 100644
index 000000000000..4402e945c74f
--- /dev/null
+++ b/sci-libs/linux-gpib/linux-gpib-4.3.6.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit readme.gentoo-r1 autotools perl-functions python-single-r1 udev
+
+# Check for latest firmware version on bump
+FW_PV="2008-08-10"
+
+DESCRIPTION="Driver library for GPIB (IEEE 488.2) hardware"
+HOMEPAGE="https://linux-gpib.sourceforge.io/"
+SRC_URI="mirror://sourceforge/linux-gpib/${P}.tar.gz
+ firmware? ( https://linux-gpib.sourceforge.io/firmware/gpib_firmware-${FW_PV}.tar.gz )
+"
+S="${WORKDIR}/${PN}-user-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="pcmcia static guile perl php python tcl doc firmware"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMONDEPEND="
+ sys-libs/readline:=
+ tcl? ( dev-lang/tcl:0= )
+ guile? ( dev-scheme/guile:12 )
+ perl? ( dev-lang/perl:= )
+ php? ( dev-lang/php:= )
+ python? ( ${PYTHON_DEPS} )
+ firmware? ( sys-apps/fxload )
+"
+RDEPEND="${COMMONDEPEND}
+ acct-group/gpib
+ ~sci-libs/linux-gpib-modules-${PV}
+"
+DEPEND="${COMMONDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+ perl? ( virtual/perl-ExtUtils-MakeMaker )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-perl.patch
+)
+
+pkg_setup() {
+ use perl && perl_set_version
+ use python && python_setup
+}
+
+src_unpack() {
+ default
+ unpack "${WORKDIR}/${P}/${PN}-user-${PV}.tar.gz"
+}
+
+src_prepare() {
+ default
+
+ # We have to use --root instead of --prefix for setup.py.
+ # Otherwise the python files are not installed properly into site-packages.
+ sed -i -e \
+ 's/--prefix=$(DESTDIR)$(prefix)/--root=$(DESTDIR)/g' \
+ language/python/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static) \
+ $(use_enable guile guile-binding) \
+ $(use_enable perl perl-binding) \
+ $(use_enable php php-binding) \
+ $(use_enable python python-binding) \
+ $(use_enable tcl tcl-binding) \
+ $(use_enable doc documentation)
+}
+
+src_install() {
+ # PYTHONDONTWRITEBYTECODE=0 is required, otherwise
+ # installation of the python files is skipped
+ FIRM_DIR=/usr/share/usb
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}" \
+ HOTPLUG_USB_CONF_DIR=/etc/hotplug/usb \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ USB_FIRMWARE_DIR=${FIRM_DIR} \
+ PYTHONDONTWRITEBYTECODE=0 \
+ docdir="/usr/share/doc/${PF}/html" install
+
+ if use perl; then
+ einfo "Installing perl module"
+ cd "${S}"/language/perl || die
+ emake DESTDIR="${ED}" install
+ perl_fix_packlist
+ perl_delete_emptybsdir
+ cd "${S}" || die
+ fi
+
+ echo "KERNEL==\"gpib[0-9]*\", MODE=\"0660\", GROUP=\"gpib\"" >> 99-gpib.rules
+ udev_dorules 99-gpib.rules
+
+ dodoc doc/linux-gpib.pdf ChangeLog AUTHORS README* NEWS
+
+ insinto /etc
+ newins util/templates/gpib.conf gpib.conf
+ newins util/templates/gpib.conf gpib.conf.example
+
+ if use pcmcia; then
+ insinto /etc/pcmcia
+ doins "${S}"/etc/pcmcia/*
+ fi
+
+ # fix rules files
+ local f
+ find "${ED}$(get_udevdir)"/rules.d -type f -print0 | while read -rd '' f ; do
+ grep -q "${ED}" "${f}" && einfo "File ${f} contains a temporary path, fixing."
+ sed -i -e "s:${ED}:/:g" "${f}"
+ done
+
+ # remove .la files
+ find "${ED}" -name '*.la' -delete || die
+
+ DOC_CONTENTS="
+As the udev rules were changed and refactored in this release it is
+necessary to remove any manually installed pre-4.3.0 gpib udev rules files
+in /etc/udev/rules.d/. The files to remove are:
+\n
+ 99-agilent_82357a.rules\n
+ 99-gpib-generic.rules\n
+ 99-ni_usb_gpib.rules\n
+\n
+You need to run the 'gpib_config' utility to setup the driver before
+you can use it. In order to do it automatically you can add to your
+start script something like this (supposing the appropriate driver
+is loaded on the startup):
+\n
+ gpib_config --minor 0
+\n
+To give a user access to the computer's gpib board you will have to add
+them to the group 'gpib' or, you could change the permissions on the device
+files /dev/gpib[0-15] to something you like better, using 'chmod'
+\n
+Edit /etc/gpib.conf to match your interface board, and any devices you wish
+to open via ibfind(). See the documentation in /usr/share/linux-gpib/html for
+more information.
+\n
+"
+
+ if use pcmcia; then
+ DOC_CONTENTS+='
+For PCMCIA cards:\n
+All files needed for a PCMCIA board were copied to /etc/pcmcia.
+You may wish to edit the options passed to the gpib_config call in the
+/etc/pcmcia/linux-gpib-pcmcia script.
+You may need to send a SIGHUP signal to the cardmgr daemon to force it
+to reload the files in /etc/pcmcia \(alternatively you could use your
+pcmcia init.d script to restart the cardmgr, or you could just reboot\).
+The driver module will be loaded as needed by the cardmgr.
+
+'
+ fi
+
+ if use firmware; then
+ DOC_CONTENTS+='
+For Agilent \(HP\) 82341C and 82341D cards:
+The firmware for these boards is uploaded by passing the appropriate
+firmware file from /usr/share/linux-gpib/hp_82341 directory to
+gpib_config using the -I or --init-data command line option. Example:\n
+gpib_config --minor 0 --init-data /usr/share/linux-gpib/hp_82341/hp_82341c_fw.bin
+'
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}