summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-05 09:12:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-05 10:27:21 +0200
commit6aa9c30d47570b241ee6d4bf509c3b9ef1198242 (patch)
treeafcd80dd8a59a7eccfa74343700b4397440f1bc2
parentdev-python/pybind11: Bump to 2.8.0 (diff)
downloadgentoo-6aa9c30d.tar.gz
gentoo-6aa9c30d.tar.bz2
gentoo-6aa9c30d.zip
dev-python/pylast: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-4.3.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index e6dcc583dfb7..030265c96299 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1 +1,2 @@
DIST pylast-4.2.1.tar.gz 39787 BLAKE2B 1f2f06671ce38bd42f7297279a58f674c3af8f66de4fe804d90e3fc178c73f09a24f65bbc4fd534da0c04f593dc5eb31f03da38a4ca969ea31a04978a603b7b4 SHA512 c1418ff1e6b6ab905d790cc83eb1a4b3172c0c28d523c2bbd641523a2e2601a84aff126dafd047f0fb9b82744bca883648e197b273026611f47671d39afd4fc6
+DIST pylast-4.3.0.tar.gz 39875 BLAKE2B 9b51c44295babc54207593e43d70ec121ddc4c4e5bea8a0936691d02c2cf996869cc3995f5b069bfe3a9208754705a716716cb6bb8aefef142723687dc07a16a SHA512 2880e142da2841775f2c48f2d5ad0adc39e6b65073a76dd6af24c65f420948755b25f7a630b95315ffbdd1f7536d9ac4570b3df01d6837f77faccf89aaf41f33
diff --git a/dev-python/pylast/pylast-4.3.0.ebuild b/dev-python/pylast/pylast-4.3.0.ebuild
new file mode 100644
index 000000000000..95af06713180
--- /dev/null
+++ b/dev-python/pylast/pylast-4.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}