summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-02-11 13:49:06 -0500
committerBrian Evans <grknight@gentoo.org>2020-02-11 13:50:14 -0500
commit6acadb595b84788e3638100714a724e19ec58a0e (patch)
tree7cc169181919dcbe9d04299107ad4f83f75130f6
parentdev-php/pecl-oauth: Version bump for 2.0.5 (diff)
downloadgentoo-6acadb595b84788e3638100714a724e19ec58a0e.tar.gz
gentoo-6acadb595b84788e3638100714a724e19ec58a0e.tar.bz2
gentoo-6acadb595b84788e3638100714a724e19ec58a0e.zip
dev-php/pecl-oauth: Drop old 2.0.4
Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/pecl-oauth/Manifest1
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.4.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-php/pecl-oauth/Manifest b/dev-php/pecl-oauth/Manifest
index dd696e1ce5bc..418f09077ac4 100644
--- a/dev-php/pecl-oauth/Manifest
+++ b/dev-php/pecl-oauth/Manifest
@@ -1,2 +1 @@
-DIST oauth-2.0.4.tgz 49359 BLAKE2B d5fb23293fc03f40e2b3a5c5ad51bce1b06a6004e1f20d1563b3db7bb79a71f70bca467348d68b4f6d2393003b4ad23debbe5877192d9e189056e86f9fc00b3e SHA512 269b579f87a9f3f229433c74937f74b9b6df453a6e05f7751ca12fa5f24c9ad62d1ebe5cdb370d33d774a0f2e244c1c685a53226dcb35c0005b5532a00c137d4
DIST oauth-2.0.5.tgz 49641 BLAKE2B eec258d8dc900c19bea19b0b1db3e1f5b103b65e1298cef0819741181811d98ab86812ab557a3457520bcb6ece48b2b0f081d23897ce06e12b715998cbc1ad2a SHA512 847f8a07aba930d606038a78915ddd9c24aab241d27b844a766e0da3caabf419fd891573524a55b40559a827b1adc1261748efabac5ed1bee45fa770935379ee
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.4.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.4.ebuild
deleted file mode 100644
index 076b3f695e02..000000000000
--- a/dev-php/pecl-oauth/pecl-oauth-2.0.4.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PHP_EXT_NAME="oauth"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-# Really only build for 7.0
-USE_PHP="php7-0 php7-1 php7-2 php7-3 php7-4"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
-LICENSE="BSD"
-SLOT="7"
-IUSE="+curl examples"
-
-DEPEND="php_targets_php7-0? ( dev-lang/php:7.0[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-1? ( dev-lang/php:7.1[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-2? ( dev-lang/php:7.2[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-3? ( dev-lang/php:7.3[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-4? (
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
-"
-RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6(-)?] )"
-
-src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
- # Disable tests that depend on header order
- rm "${S}/tests/bug16946.phpt" "${S}/tests/overflow_redir.phpt" || die
- php-ext-source-r3_src_prepare
- else
- eapply_user
- fi
-}
-
-src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
- local PHP_EXT_ECONF_ARGS=(
- --enable-oauth
- $(use_with curl)
- )
-
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
- php-ext-pecl-r3_src_install
- fi
-}