summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-03 08:51:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 09:27:48 +0100
commit6ada0d6fa619b68b826130574ab9aafc71eaf5c2 (patch)
treea40a5923c795cc4c607ce7d882b999de812b3556
parentdev-python/pip-run: Keyword 8.8.0 x86, #832036 (diff)
downloadgentoo-6ada0d6f.tar.gz
gentoo-6ada0d6f.tar.bz2
gentoo-6ada0d6f.zip
dev-python/pytables: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytables/Manifest1
-rw-r--r--dev-python/pytables/files/pytables-3.6.1-big-endian-tests-skip-subset.patch36
-rw-r--r--dev-python/pytables/files/pytables-3.6.1-numpy-float.patch176
-rw-r--r--dev-python/pytables/files/pytables-3.6.1-py310.patch49
-rw-r--r--dev-python/pytables/pytables-3.6.1-r2.ebuild89
5 files changed, 0 insertions, 351 deletions
diff --git a/dev-python/pytables/Manifest b/dev-python/pytables/Manifest
index 0ef697796364..c456f554b2d0 100644
--- a/dev-python/pytables/Manifest
+++ b/dev-python/pytables/Manifest
@@ -1,2 +1 @@
-DIST tables-3.6.1.tar.gz 4641089 BLAKE2B 4ef44b1263f40babe6719bac911ab191e9cb0c58c377705b755fa83f1fba5af1d0fab10b0b45bd6af619a9dce4842a80afad8d8fbab64c3be4f35a1b3f117ee3 SHA512 7f018b70251095049bce9075be4e19f72efba9d39121a35c4521f634b1dd5b81ab6de47df3bb44ad6b8b2dbdbff4e6d0985ad1a7b2f13b44f920c0935e5830ff
DIST tables-3.7.0.tar.gz 8227955 BLAKE2B 0d5b7b765375c4787f1210138e5fd02e3c0ce429ef209a3a8d4fd3bc094f68486ab6f4d0a960ce86efea6991ed691ef2a3e9e8f37a49fe91cb8d6372cadea80e SHA512 eaa368d063b5fad87e6d0f9ab6f02da0b2a3542740a52fe8c2bb58e41121495d07b6d2710ad402a28891294aa61a11238c6a7e2cf2933a1bb11391b79cf4fd13
diff --git a/dev-python/pytables/files/pytables-3.6.1-big-endian-tests-skip-subset.patch b/dev-python/pytables/files/pytables-3.6.1-big-endian-tests-skip-subset.patch
deleted file mode 100644
index 6a492a1a581f..000000000000
--- a/dev-python/pytables/files/pytables-3.6.1-big-endian-tests-skip-subset.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-https://bugs.gentoo.org/805995
-https://github.com/PyTables/PyTables/issues/735
-https://sources.debian.org/src/pytables/3.6.1-5/debian/patches/0005-Skip-index-backcompat-tests-on-bingendian.patch/
-
-From: Antonio Valentino <antonio.valentino@tiscali.it>
-Date: Sat, 3 Aug 2019 16:22:13 +0000
-Subject: Skip index backcompat tests on bingendian
-
-Forwarded: not-needed
---- a/tables/tests/test_index_backcompat.py
-+++ b/tables/tests/test_index_backcompat.py
-@@ -6,8 +6,10 @@ from tables.tests.common import verbose
- from tables.tests.common import unittest, test_filename
- from tables.tests.common import PyTablesTestCase as TestCase
-
-+import sys
-
- # Check indexes from PyTables version 2.0
-+@unittest.skipIf(sys.byteorder != 'little', 'broken on big-endian')
- class IndexesTestCase(common.TestFileMixin, TestCase):
-
- def setUp(self):
-@@ -145,11 +147,13 @@ class IndexesTestCase(common.TestFileMixin, TestCase):
-
-
- # Check indexes from PyTables version 2.0
-+@unittest.skipIf(sys.byteorder != 'little', 'broken on big-endian')
- class Indexes2_0TestCase(IndexesTestCase):
- h5fname = test_filename("indexes_2_0.h5")
-
-
- # Check indexes from PyTables version 2.1
-+@unittest.skipIf(sys.byteorder != 'little', 'broken on big-endian')
- class Indexes2_1TestCase(IndexesTestCase):
- h5fname = test_filename("indexes_2_1.h5")
-
diff --git a/dev-python/pytables/files/pytables-3.6.1-numpy-float.patch b/dev-python/pytables/files/pytables-3.6.1-numpy-float.patch
deleted file mode 100644
index 71fa3b85dacf..000000000000
--- a/dev-python/pytables/files/pytables-3.6.1-numpy-float.patch
+++ /dev/null
@@ -1,176 +0,0 @@
-From d2a480d14f29fb1d2baee292bc6a2cca4817dcbd Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
-Date: Sun, 24 Jan 2021 16:36:21 +0100
-Subject: [PATCH] Use lowercase float/int as numpy dtype
-
-Float64 is gone with numpy 1.20, which causes doctests to fail
-(https://bugzilla.redhat.com/show_bug.cgi?id=1914335).
-
-Similarly all uses of Float32, Int32 should be replaced by float32 and int32.
-
->>> numpy.__version__
-'1.19.4'
->>> [k for k in numpy.sctypeDict.keys() if str(k).lower().startswith('float')]
-['float16', 'Float16', 'float32', 'Float32', 'float64', 'Float64', 'float128', 'Float128', 'float_', 'float']
-
->>> numpy.__version__
-'1.20.0rc2'
->>> [k for k in numpy.sctypeDict.keys() if str(k).lower().startswith('float')]
-['float16', 'float32', 'float64', 'float128', 'float_', 'float']
----
- bench/bsddb-table-bench.py | 10 +++++-----
- bench/postgres-search-bench.py | 4 ++--
- bench/pytables-search-bench.py | 6 +++---
- bench/recarray2-test.py | 2 +-
- bench/shelve-bench.py | 10 +++++-----
- bench/sqlite-search-bench.py | 4 ++--
- tables/atom.py | 2 +-
- 7 files changed, 19 insertions(+), 19 deletions(-)
-
-diff --git a/bench/bsddb-table-bench.py b/bench/bsddb-table-bench.py
-index dd9f875b..a2e02361 100644
---- a/bench/bsddb-table-bench.py
-+++ b/bench/bsddb-table-bench.py
-@@ -83,11 +83,11 @@ def createFile(filename, totalrows, recsize, verbose):
- # Get the record object associated with the new table
- if recsize == "big":
- isrec = Big()
-- arr = np.array(np.arange(32), type=np.Float64)
-- arr2 = np.array(np.arange(32), type=np.Float64)
-+ arr = np.array(np.arange(32), type=np.float64)
-+ arr2 = np.array(np.arange(32), type=np.float64)
- elif recsize == "medium":
- isrec = Medium()
-- arr = np.array(np.arange(2), type=np.Float64)
-+ arr = np.array(np.arange(2), type=np.float64)
- else:
- isrec = Small()
- # print d
-@@ -107,8 +107,8 @@ def createFile(filename, totalrows, recsize, verbose):
- #d['TDCcount'] = i % 256
- d['ADCcount'] = (i * 256) % (1 << 16)
- if recsize == "big":
-- #d.float1 = np.array([i]*32, np.Float64)
-- #d.float2 = np.array([i**2]*32, np.Float64)
-+ #d.float1 = np.array([i]*32, np.float64)
-+ #d.float2 = np.array([i**2]*32, np.float64)
- arr[0] = 1.1
- d['float1'] = arr
- arr2[0] = 2.2
-diff --git a/bench/postgres-search-bench.py b/bench/postgres-search-bench.py
-index d2c9f4f4..7fe83f6a 100644
---- a/bench/postgres-search-bench.py
-+++ b/bench/postgres-search-bench.py
-@@ -15,11 +15,11 @@ def flatten(l):
-
-
- def fill_arrays(start, stop):
-- col_i = numpy.arange(start, stop, type=numpy.Int32)
-+ col_i = numpy.arange(start, stop, type=numpy.int32)
- if userandom:
- col_j = numpy.random.uniform(0, nrows, size=[stop - start])
- else:
-- col_j = numpy.array(col_i, type=numpy.Float64)
-+ col_j = numpy.array(col_i, type=numpy.float64)
- return col_i, col_j
-
- # Generator for ensure pytables benchmark compatibility
-diff --git a/bench/pytables-search-bench.py b/bench/pytables-search-bench.py
-index 726d30b1..6417186b 100644
---- a/bench/pytables-search-bench.py
-+++ b/bench/pytables-search-bench.py
-@@ -37,11 +37,11 @@ def create_db(filename, nrows):
- stop = (j + 1) * step
- if stop > nrows:
- stop = nrows
-- arr_f8 = np.arange(i, stop, type=np.Float64)
-- arr_i4 = np.arange(i, stop, type=np.Int32)
-+ arr_f8 = np.arange(i, stop, type=np.float64)
-+ arr_i4 = np.arange(i, stop, type=np.int32)
- if userandom:
- arr_f8 += np.random.normal(0, stop * scale, shape=[stop - i])
-- arr_i4 = np.array(arr_f8, type=np.Int32)
-+ arr_i4 = np.array(arr_f8, type=np.int32)
- recarr = np.rec.fromarrays([arr_i4, arr_i4, arr_f8, arr_f8])
- table.append(recarr)
- j += 1
-diff --git a/bench/recarray2-test.py b/bench/recarray2-test.py
-index a8602d80..bf55389d 100644
---- a/bench/recarray2-test.py
-+++ b/bench/recarray2-test.py
-@@ -22,7 +22,7 @@ delta = 0.000001
- # Creation of recarrays objects for test
- x1 = np.array(np.arange(reclen))
- x2 = chararray.array(None, itemsize=7, shape=reclen)
--x3 = np.array(np.arange(reclen, reclen * 3, 2), np.Float64)
-+x3 = np.array(np.arange(reclen, reclen * 3, 2), np.float64)
- r1 = recarray.fromarrays([x1, x2, x3], names='a,b,c')
- r2 = recarray2.fromarrays([x1, x2, x3], names='a,b,c')
-
-diff --git a/bench/shelve-bench.py b/bench/shelve-bench.py
-index d30739d8..a591ed1e 100644
---- a/bench/shelve-bench.py
-+++ b/bench/shelve-bench.py
-@@ -65,8 +65,8 @@ def createFile(filename, totalrows, recsize):
- # Get the record object associated with the new table
- if recsize == "big":
- d = Big()
-- arr = NA.array(NA.arange(32), type=NA.Float64)
-- arr2 = NA.array(NA.arange(32), type=NA.Float64)
-+ arr = NA.array(NA.arange(32), type=NA.float64)
-+ arr2 = NA.array(NA.arange(32), type=NA.float64)
- elif recsize == "medium":
- d = Medium()
- else:
-@@ -87,15 +87,15 @@ def createFile(filename, totalrows, recsize):
- #d.TDCcount = i % 256
- d.ADCcount = (i * 256) % (1 << 16)
- if recsize == "big":
-- #d.float1 = NA.array([i]*32, NA.Float64)
-- #d.float2 = NA.array([i**2]*32, NA.Float64)
-+ #d.float1 = NA.array([i]*32, NA.float64)
-+ #d.float2 = NA.array([i**2]*32, NA.float64)
- arr[0] = 1.1
- d.float1 = arr
- arr2[0] = 2.2
- d.float2 = arr2
- pass
- else:
-- d.float1 = NA.array([i ** 2] * 2, NA.Float64)
-+ d.float1 = NA.array([i ** 2] * 2, NA.float64)
- #d.float1 = float(i)
- #d.float2 = float(i)
- d.grid_i = i
-diff --git a/bench/sqlite-search-bench.py b/bench/sqlite-search-bench.py
-index 76dc7c57..dc611695 100644
---- a/bench/sqlite-search-bench.py
-+++ b/bench/sqlite-search-bench.py
-@@ -136,10 +136,10 @@ CREATE INDEX ivar3 ON small(var3);
- if randomvalues:
- var3 = np.random.uniform(minimum, maximum, shape=[j - i])
- else:
-- var3 = np.arange(i, j, type=np.Float64)
-+ var3 = np.arange(i, j, type=np.float64)
- if noise:
- var3 += np.random.uniform(-3, 3, shape=[j - i])
-- var2 = np.array(var3, type=np.Int32)
-+ var2 = np.array(var3, type=np.int32)
- var1 = np.array(None, shape=[j - i], dtype='s4')
- if not heavy:
- for n in range(j - i):
-diff --git a/tables/atom.py b/tables/atom.py
-index f92e16ad..f93d915b 100644
---- a/tables/atom.py
-+++ b/tables/atom.py
-@@ -338,7 +338,7 @@ class Atom(metaclass=MetaAtom):
- Traceback (most recent call last):
- ...
- ValueError: unknown NumPy scalar type: 'S5'
-- >>> Atom.from_sctype('Float64')
-+ >>> Atom.from_sctype('float64')
- Float64Atom(shape=(), dflt=0.0)
-
- """
---
-2.32.0
-
diff --git a/dev-python/pytables/files/pytables-3.6.1-py310.patch b/dev-python/pytables/files/pytables-3.6.1-py310.patch
deleted file mode 100644
index 600516d16396..000000000000
--- a/dev-python/pytables/files/pytables-3.6.1-py310.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 2431150d691f5ccdb3da204a46e346c156ea2523 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
-Date: Mon, 16 Nov 2020 10:53:05 +0100
-Subject: [PATCH] doctest: adjust __init__ TypeError formatting
-
-Python3.10 includes the class name in the TypeError string for
-__init__(), so the literal match does not work anymore.
----
- tables/atom.py | 4 ++--
- tables/filters.py | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tables/atom.py b/tables/atom.py
-index 81d37c54..9cfd8609 100644
---- a/tables/atom.py
-+++ b/tables/atom.py
-@@ -569,10 +569,10 @@ class Atom(metaclass=MetaAtom):
- >>> atom3 = atom1.copy(shape=(2, 2))
- >>> print(atom3)
- Int32Atom(shape=(2, 2), dflt=0)
-- >>> atom1.copy(foobar=42)
-+ >>> atom1.copy(foobar=42) #doctest: +ELLIPSIS
- Traceback (most recent call last):
- ...
-- TypeError: __init__() got an unexpected keyword argument 'foobar'
-+ TypeError: ...__init__() got an unexpected keyword argument 'foobar'
-
- """
- newargs = self._get_init_args()
-diff --git a/tables/filters.py b/tables/filters.py
-index f809ce77..7cb9b02d 100644
---- a/tables/filters.py
-+++ b/tables/filters.py
-@@ -432,10 +432,10 @@ class Filters:
- Filters(complevel=0, shuffle=False, bitshuffle=False, fletcher32=False, least_significant_digit=None)
- >>> print(filters3)
- Filters(complevel=1, complib='zlib', shuffle=False, bitshuffle=False, fletcher32=False, least_significant_digit=None)
-- >>> filters1.copy(foobar=42)
-+ >>> filters1.copy(foobar=42) #doctest: +ELLIPSIS
- Traceback (most recent call last):
- ...
-- TypeError: __init__() got an unexpected keyword argument 'foobar'
-+ TypeError: ...__init__() got an unexpected keyword argument 'foobar'
-
- """
-
---
-2.32.0
-
diff --git a/dev-python/pytables/pytables-3.6.1-r2.ebuild b/dev-python/pytables/pytables-3.6.1-r2.ebuild
deleted file mode 100644
index 39b290e8a448..000000000000
--- a/dev-python/pytables/pytables-3.6.1-r2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-MY_PN=tables
-MY_P=${MY_PN}-${PV}
-
-inherit distutils-r1
-
-DESCRIPTION="Hierarchical datasets for Python"
-HOMEPAGE="https://www.pytables.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-# See https://github.com/PyTables/PyTables/issues/912 for hdf5 upper bound
-DEPEND="
- app-arch/bzip2:0=
- app-arch/lz4:0=
- >=app-arch/zstd-1.0.0:=
- >=dev-libs/c-blosc-1.11.1:0=
- dev-libs/lzo:2=
- >=dev-python/numpy-1.8.1[${PYTHON_USEDEP}]
- <sci-libs/hdf5-1.12:=
-"
-RDEPEND="${DEPEND}
- >=dev-python/numexpr-2.5.2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/cython-0.21[${PYTHON_USEDEP}]
- virtual/pkgconfig
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- ${RDEPEND}
- )
-"
-
-DOCS=( RELEASE_NOTES.txt THANKS )
-
-PATCHES=(
- "${FILESDIR}"/${P}-numpy-float.patch
- "${FILESDIR}"/${P}-py310.patch
- "${FILESDIR}"/${PN}-3.6.1-big-endian-tests-skip-subset.patch
-)
-
-python_prepare_all() {
- export {BLOSC,BZIP2,LZO,HDF5}_DIR="${ESYSROOT}"/usr
- export PYTABLES_NO_EMBEDDED_LIBS=1
- export USE_PKGCONFIG=TRUE
-
- rm tables/*.c || die
- sed -e "s:/usr:${EPREFIX}/usr:g" \
- -i setup.py || die
- rm -r c-blosc/{blosc,internal-complibs} || die
- sed -i -e '/_version/ s/\\s\*/\\s\+/' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile -j1
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- "${EPYTHON}" tables/tests/test_all.py -v || die
-}
-
-python_install_all() {
- if use doc; then
- DOCS+=( doc/scripts )
- fi
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- dodoc -r contrib
- docompress -x /usr/share/doc/${PF}/examples
- docompress -x /usr/share/doc/${PF}/contrib
- fi
-}