summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-30 06:24:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-30 06:48:17 +0100
commit6adf78757ab3b2601beef1490df7c1b137e17220 (patch)
tree41dec14ed1dc916bf94dc097a1b7c4a96a7abb20
parentdev-python/google-api-python-client: Bump to 2.109.0 (diff)
downloadgentoo-6adf78757ab3b2601beef1490df7c1b137e17220.tar.gz
gentoo-6adf78757ab3b2601beef1490df7c1b137e17220.tar.bz2
gentoo-6adf78757ab3b2601beef1490df7c1b137e17220.zip
dev-python/trove-classifiers: Bump to 2023.11.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.11.29.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index ad0863a1f127..5b00bb107e7c 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,2 +1,3 @@
DIST trove-classifiers-2023.11.14.tar.gz 15895 BLAKE2B 559cfbf0a28da834130d4d6e74b63454a3c09ff198cd6f88392031f52609a54b6f58a3015bb29179ebead94b7b498a51a4f426f4e9fc9084d7cf11a0f9a9cc16 SHA512 f014eb404902a42b7ceac23b1f5cd1b256c05c2de2d1a630c067528826593cfb1a10d6de0851fa68715665e3165889eb39b61a518138fd81bf29c72489847146
DIST trove-classifiers-2023.11.22.tar.gz 15903 BLAKE2B 02437414e382a02da079f1ee7b0b5e12575a2915de3233a89ddec128c113b95de9d469b38867f8ae46ac795c31c9198a331489de6965bff44fae2c20a55584ed SHA512 5f986562868a116a7932ec6f0d9668f81f7867a28b4d989ccac892f83d7edb9a6e48fb3cd9cf9b76c92634e7a418705566d059df02c9624146193076d9204498
+DIST trove-classifiers-2023.11.29.tar.gz 15918 BLAKE2B 3e216aa24a458f5c65a20b2589dff34c382c3e1ccba5274377b09bcc254fafb077dfd3f82b0f1c998a9c34b20f35eca27bd7d8103b631a03eb87a9c1525c057e SHA512 fdeb6bbddbb3ad640112827b55f4b0a2201c79e2a4013d2d621bf0a6168d87861ad1802b0805747fc7d9e8be7e1954d58b83fd4fde6f3394cec2fa3aa88f0dca
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.11.29.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.11.29.ebuild
new file mode 100644
index 000000000000..9198d34d2369
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2023.11.29.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}