summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-21 11:40:17 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-21 11:40:17 +0200
commit6af9a4e89616a819c4352c04d9e1507cf98894c6 (patch)
treec0c3ab80dea112c9043606fc4a708768bac1e369
parentdev-util/dialog: drop 1.3.20211214 (diff)
downloadgentoo-6af9a4e89616a819c4352c04d9e1507cf98894c6.tar.gz
gentoo-6af9a4e89616a819c4352c04d9e1507cf98894c6.tar.bz2
gentoo-6af9a4e89616a819c4352c04d9e1507cf98894c6.zip
dev-util/strace: drop 5.15
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-5.15.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index 4de429503f8f..e711c7091129 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -1,3 +1,2 @@
-DIST strace-5.15.tar.xz 2248664 BLAKE2B fff08e49552ad1208b658f91e37c540cc7315ac255aba2e69db5bfeb942114b865f1114a45663481f1ab967db45d187bdbcf70ffe80449169df0c37ff82a1a94 SHA512 67251792ad0fb7f44013c3ae5e5b757106223c9d123d349e31de7565e0f2bfdc6bbd46a9c269e58508bd288ee70f104f8e2185f2203bd91431c5c776db0d9384
DIST strace-5.17.tar.xz 2281220 BLAKE2B 27e7dc19302c58144b0a7d8de41f717760b8e3cde4ab56892045727597bbfc894bf8f137aee476548c2d16d1e9c8005f931f31a5d2f8bfc4ce5565c2aa01f1ec SHA512 1b63cf7e6e339333b9d24fa20232409192abc815f2ebe2e336ef4acc039cd06c976b3c12e9ce993491a0e6b86c26b90ceba962f580e894b1ff5ab9863bdfcc44
DIST strace-5.18.tar.xz 2307412 BLAKE2B 658d17d2137344550ea3c2ece54708387c3b78020dbade45a7ef04905dc9d4703fa8d44802cca5a9448d096a7210d0178d8d78caab7e504fa998d1f9a0b59c65 SHA512 99418b84a5e2049cb6fe32eed19ddcb61bbefb25220550c67d92cd7bc3d44ae5d87ac228b3e1c207166b9bfdae55c624a0f4e603004599fb7ea3143bbccc749e
diff --git a/dev-util/strace/strace-5.15.ebuild b/dev-util/strace/strace-5.15.ebuild
deleted file mode 100644
index 9c248f5d99ea..000000000000
--- a/dev-util/strace/strace-5.15.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/strace/strace.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="https://strace.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="aio perl selinux static unwind elfutils"
-REQUIRED_USE="?? ( unwind elfutils )"
-
-BDEPEND="virtual/pkgconfig"
-LIB_DEPEND="
- unwind? ( sys-libs/libunwind[static-libs(+)] )
- elfutils? ( dev-libs/elfutils[static-libs(+)] )
- selinux? ( sys-libs/libselinux[static-libs(+)] )
-"
-# strace only uses the header from libaio to decode structs
-DEPEND="
- static? ( ${LIB_DEPEND} )
- aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers
-"
-RDEPEND="
- !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- perl? ( dev-lang/perl )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.11-static.patch"
-)
-
-src_prepare() {
- default
-
- eautoreconf
-
- if [[ ! -e configure ]] ; then
- # git generation
- sed /autoreconf/d -i bootstrap || die
- ./bootstrap || die
- eautoreconf
- [[ ! -e CREDITS ]] && cp CREDITS{.in,}
- fi
-
- # Stub out the -k test since it's known to be flaky. bug #545812
- sed -i '1iexit 77' tests*/strace-k.test || die
-}
-
-src_configure() {
- # Set up the default build settings, and then use the names strace expects.
- tc-export_build_env BUILD_{CC,CPP}
- local v bv
- for v in CC CPP {C,CPP,LD}FLAGS ; do
- bv="BUILD_${v}"
- export "${v}_FOR_BUILD=${!bv}"
- done
-
- filter-lfs-flags # configure handles this sanely
-
- export ac_cv_header_libaio_h=$(usex aio)
- use elibc_musl && export ac_cv_header_stdc=no
-
- local myeconfargs=(
- --disable-gcc-Werror
-
- # Don't require mpers support on non-multilib systems. #649560
- --enable-mpers=check
-
- $(use_enable static)
- $(use_with unwind libunwind)
- $(use_with elfutils libdw)
- $(use_with selinux libselinux)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- if has usersandbox ${FEATURES} ; then
- # bug #643044
- ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..."
- return 0
- fi
-
- default
-}
-
-src_install() {
- default
-
- if use perl ; then
- exeinto /usr/bin
- doexe src/strace-graph
- fi
- dodoc CREDITS
-}