summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 07:11:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 07:11:32 +0100
commit6b0287988fe38ed039f520e264e94a51e53fd09f (patch)
tree79077d4738feac91506bb5aca0a8b2003dba8f8b
parentdev-util/debootstrap: Stabilize 1.0.128_p2 ppc, #883565 (diff)
downloadgentoo-6b028798.tar.gz
gentoo-6b028798.tar.bz2
gentoo-6b028798.zip
dev-python/botocore: Bump to 1.29.60
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.60.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 3b4ef1c636da..8e2b392b5b42 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.29.54.gh.tar.gz 11127081 BLAKE2B 7c2d11d968ca6a4d3b23b12c44cb8f0
DIST botocore-1.29.57.gh.tar.gz 11132049 BLAKE2B 748a8b709cb6bff1a1bb38757ad68c31aa680589ed59e7c3f73b6563a5b9572ace96102ffda56643d33f0dee98f30f8443a431c7869ccfe54a311964ce781b5b SHA512 adbd760b8238b259bcc1eb3ba42cdb702b60eb6fece73a5bda5129a974826655157e702cef6a1114c2e3bd036b1cf22ebbead6e78bf88129fe68b02de1f38dae
DIST botocore-1.29.58.gh.tar.gz 11135559 BLAKE2B 937b00f1a3c4e3ec818846549bc0cef391c86d3fee9bdd53285111e51c2c52145e7e904020511ed32f2247dd4f150f036f40feeac1a6f899781aff057f9a6d85 SHA512 5cfe5fb174cc14018cd2b7b7af15110665d7ca22f5ae827ba939ce12e71a45e9b5cab8d7ec656fa94c450d46c430a5541cd5bfe92d82da868424db4f8fa4fb2e
DIST botocore-1.29.59.gh.tar.gz 11131182 BLAKE2B fa85e1f8dc3c366f7a7fb3e9b06dd298b1ad62be882891df3414289aa9e88bff72753690a1438e6040aefb7cafa1718a70c940e8cd2b4e743df44013b5748ef6 SHA512 9a4811b44c67652cacc899d1d84d4db1305cb60e73dd47d7f543b85ec37f921cab00a51d67b48ab6a215be8f7543e30c54585e0fb337085e1b75774b053c4bf3
+DIST botocore-1.29.60.gh.tar.gz 11129718 BLAKE2B 690d80fa12e9df141402019dc45ef2b0807669132ede8af6b57a45a172da78fda3de017a6392920885125763f221a1dbc6a406cb5cf85e66fb50916cc58ba15f SHA512 b8fb6567db599e09bc000ed0b178ff2799c45edeaf21b122a2028b83a50ef7aa27f874b8dec034f6dc61738c4fd3a218db92b26e104cfa2b3ed6f818d034108e
diff --git a/dev-python/botocore/botocore-1.29.60.ebuild b/dev-python/botocore/botocore-1.29.60.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.60.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}