summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:40:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:41 +0100
commit6b07f08fbd6975de27d3cc87667002533d91dd4e (patch)
treec8344595ebc150dacd2be89919ce343beaf15ab3
parentprofiles: mask musl on riscv32 (not supported) (diff)
downloadgentoo-6b07f08f.tar.gz
gentoo-6b07f08f.tar.bz2
gentoo-6b07f08f.zip
dev-python/consonance: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/consonance/consonance-0.1.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/consonance/consonance-0.1.5-r1.ebuild b/dev-python/consonance/consonance-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..71911ed00e7d
--- /dev/null
+++ b/dev-python/consonance/consonance-0.1.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="WhatsApp's handshake implementation using Noise Protocol"
+HOMEPAGE="https://github.com/tgalal/consonance"
+SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+# Tests require an active internet connection
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/dissononce[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/python-axolotl-curve25519[${PYTHON_USEDEP}]
+ dev-python/transitions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.py
+}