summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-21 03:20:56 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-21 03:23:24 -0400
commit6b1491d2907fa9d4a216cd461615e0c1cde75fce (patch)
tree5e6485cbd9e7aea612ecdf4bc2d152cb4434fd92
parentsys-apps/eza: fix build with >=libgit2-1.8.0 (diff)
downloadgentoo-6b1491d2907fa9d4a216cd461615e0c1cde75fce.tar.gz
gentoo-6b1491d2907fa9d4a216cd461615e0c1cde75fce.tar.bz2
gentoo-6b1491d2907fa9d4a216cd461615e0c1cde75fce.zip
sys-apps/bat: fix build with >=libgit2-1.8.0
libgit2-sys crate has a upper bound for <1.8.0 and refuses to build otherwise, but not seeing(?) any issues with it. Just a quick emergency fix, will likely be fixed next libgit2-sys version. Kept full version in the sed's path rather than a glob to force re-checking this when the crate is bumped. Alternatively could drop LIBGIT2_NO_VENDOR or set an upper bound in RDEPEND, but does not seem necessary. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--sys-apps/bat/bat-0.24.0-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-apps/bat/bat-0.24.0-r1.ebuild b/sys-apps/bat/bat-0.24.0-r1.ebuild
index 64152c55b844..0c0d2c793320 100644
--- a/sys-apps/bat/bat-0.24.0-r1.ebuild
+++ b/sys-apps/bat/bat-0.24.0-r1.ebuild
@@ -219,6 +219,14 @@ DOCS=( README.md CHANGELOG.md doc/alternatives.md )
QA_FLAGS_IGNORED="usr/bin/${PN}"
+src_prepare() {
+ default
+
+ # libgit2-sys unnecessarily(?) requests <libgit2-1.8.0, bump to 2 for now
+ sed -e '/range_version/s/1\.8\.0/2/' \
+ -i "${ECARGO_VENDOR}"/libgit2-sys-0.16.1+1.7.1/build.rs || die
+}
+
src_configure() {
export RUSTONIG_SYSTEM_LIBONIG=1
export LIBGIT2_NO_VENDOR=1