summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-03 23:57:27 +0000
committerSam James <sam@gentoo.org>2022-11-03 23:58:15 +0000
commit6b19b1fec1b69d44e2fd8a8fdc64c874cfa195c8 (patch)
tree0ede32c9e55136572d52277402aa91b1b4eb4bf5
parentnet-mail/dot-forward: fix ebuild to work with clang16 (diff)
downloadgentoo-6b19b1fe.tar.gz
gentoo-6b19b1fe.tar.bz2
gentoo-6b19b1fe.zip
app-editors/neovim: fix CMake patch for 0.8.0-r1
Fixes: bb9639a94ba59a7b247838d36f6af9a37af61f2d Fixes: 317d433897aa1ecb0138d97df6d9374ace4005b4 Closes: https://bugs.gentoo.org/879305 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch (renamed from app-editors/neovim/files/neovim-9999-cmake-release-type.patch)22
-rw-r--r--app-editors/neovim/neovim-0.8.0-r1.ebuild3
2 files changed, 12 insertions, 13 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch
index 8c24b6b6123f..8114e2a92b74 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
+++ b/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch
@@ -1,16 +1,16 @@
Ensure that :checkhealth is happy with the Gentoo build type.
https://bugs.gentoo.org/757744
---- a/runtime/lua/nvim/health.lua
-+++ b/runtime/lua/nvim/health.lua
-@@ -149,7 +149,7 @@ local function check_performance()
- let s:buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
- if empty(s:buildtype)
- call health#report_error('failed to get build type from :version')
-- elseif s:buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
-+ elseif s:buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
- call health#report_ok(s:buildtype)
- else
- call health#report_info(s:buildtype)
+--- a/runtime/autoload/health/nvim.vim
++++ b/runtime/autoload/health/nvim.vim
+@@ -135,7 +135,7 @@ function! s:check_performance() abort
+ let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
+ if empty(buildtype)
+ call health#report_error('failed to get build type from :version')
+- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
++ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
+ call health#report_ok(buildtype)
+ else
+ call health#report_info(buildtype)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,12 +137,6 @@ else()
diff --git a/app-editors/neovim/neovim-0.8.0-r1.ebuild b/app-editors/neovim/neovim-0.8.0-r1.ebuild
index fe675b291f83..60b97a82d314 100644
--- a/app-editors/neovim/neovim-0.8.0-r1.ebuild
+++ b/app-editors/neovim/neovim-0.8.0-r1.ebuild
@@ -73,13 +73,12 @@ PATCHES=()
if [[ ${PV} == 9999 ]]; then
PATCHES+=(
"${FILESDIR}/${PN}-9999-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-9999-cmake-release-type.patch"
"${FILESDIR}/${PN}-9999-cmake-darwin.patch"
)
else
PATCHES+=(
"${FILESDIR}/${PN}-9999-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-9999-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-0.8.0-cmake-release-type.patch"
"${FILESDIR}/${PN}-9999-cmake-darwin.patch"
)
fi