summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-05-30 12:38:22 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-05-30 12:38:39 -0400
commit6b2955f24cb027e3aa10e6dfde91d792a4b08a5c (patch)
tree3f8b0b2c6ee88ec894a7eaeef091eff7a0f16a50
parentx11-drivers/nvidia-drivers: fix direct c++ with USE=kernel-open (diff)
downloadgentoo-6b2955f2.tar.gz
gentoo-6b2955f2.tar.bz2
gentoo-6b2955f2.zip
sys-libs/argp-standalone: bump to version 1.5.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--sys-libs/argp-standalone/Manifest1
-rw-r--r--sys-libs/argp-standalone/argp-standalone-1.5.0.ebuild42
-rw-r--r--sys-libs/argp-standalone/files/argp-standalone-1.5.0-shared.patch53
3 files changed, 96 insertions, 0 deletions
diff --git a/sys-libs/argp-standalone/Manifest b/sys-libs/argp-standalone/Manifest
index 1579c67dee13..7dd4ff4a8e5d 100644
--- a/sys-libs/argp-standalone/Manifest
+++ b/sys-libs/argp-standalone/Manifest
@@ -1,2 +1,3 @@
DIST argp-standalone-1.3.tar.gz 130255 BLAKE2B 0848a0e7a98cfa09de52fa152eb9a793a9bf25c1edfc7401851ef134b62c051ad6ef2134d6f528e167046be582be23f311e74614c5511d659060addc14de6b2f SHA512 58c3feb8852b90248fff39e49b5019bd0dcf646790c3eaf70c3262eb81dda31a61dc0a45963c7b4a010e80fc14b37288dcb3b3ef48d02f2d33dd72c1c62e62d9
DIST argp-standalone-1.4.1.tar.gz 58158 BLAKE2B aa55965d6c4a9d61e82a5f3af7a62bf1a35b82ad91c87b4b31a6fa314ba0bcf30667137b420ccae5fbe24301c994971ef48c8dfa4db48620e56edc4300fbd961 SHA512 c5f07e88434589a13a2e88e66d1142b581f19aa82da28507f3c31ea782e080a13a4504d8108c003b5d3c8a3aa20f52ea5e81f337c11a4b1342b16361d4877c1c
+DIST argp-standalone-1.5.0.tar.gz 65889 BLAKE2B 01f4ceb3ad18be534605db09db708f17ab5df6bfd8fc0259451a70163c8e9bda92c4f9445e98d6b6cc0bc19bc61b8b122eddacf96bd026fc2ed0db00dda318f3 SHA512 fa2eb61ea00f7a13385e5c1e579dd88471d6ba3a13b6353e924fe71914b90b40688b42a9f1789bc246e03417fee1788b1990753cda8c8d4a544e85f26b63f9e2
diff --git a/sys-libs/argp-standalone/argp-standalone-1.5.0.ebuild b/sys-libs/argp-standalone/argp-standalone-1.5.0.ebuild
new file mode 100644
index 000000000000..29f3f326a366
--- /dev/null
+++ b/sys-libs/argp-standalone/argp-standalone-1.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Standalone argp library for use with musl"
+HOMEPAGE="https://github.com/argp-standalone/argp-standalone"
+SRC_URI="https://github.com/argp-standalone/argp-standalone/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain GPL-2 GPL-3 XC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
+IUSE="static-libs"
+
+DEPEND="!sys-libs/glibc"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-shared.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags "-fgnu89-inline"
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ insinto /usr/include
+ doins argp.h
+}
diff --git a/sys-libs/argp-standalone/files/argp-standalone-1.5.0-shared.patch b/sys-libs/argp-standalone/files/argp-standalone-1.5.0-shared.patch
new file mode 100644
index 000000000000..1c6c599942c8
--- /dev/null
+++ b/sys-libs/argp-standalone/files/argp-standalone-1.5.0-shared.patch
@@ -0,0 +1,53 @@
+Initially added in https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cb196546c62e9894a46900e8078f753388d4cc1a.
+Commit mentions it being from Debian but not found any other references yet.
+
+We use -largp fairly extensively across the tree which this patch
+accommodates (easier than forcing includes?).
+--- a/Makefile.am 2022-05-03 03:41:05.000000000 -0400
++++ b/Makefile.am 2022-05-30 12:28:33.850249380 -0400
+@@ -21,19 +21,19 @@
+ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = . testsuite
+
+-LIBOBJS = @LIBOBJS@
++LTLIBOBJS = @LTLIBOBJS@
+
+-noinst_LIBRARIES = libargp.a
++lib_LTLIBRARIES = libargp.la
+ noinst_PROGRAMS = argp-test
+ noinst_HEADERS = argp.h argp-fmtstream.h argp-namefrob.h # argp-comp.h
+
+ EXTRA_DIST = mempcpy.c strchrnul.c strndup.c Versions
+
+ # Leaves out argp-fs-xinl.c and argp-xinl.c
+-libargp_a_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
++libargp_la_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
+ argp-help.c argp-parse.c argp-pv.c \
+ argp-pvh.c
+
+-libargp_a_LIBADD = $(LIBOBJS)
++libargp_la_LIBADD = $(LTLIBOBJS)
+
+-argp_test_LDADD = libargp.a
++argp_test_LDADD = libargp.la
+--- a/configure.ac 2022-05-03 03:41:05.000000000 -0400
++++ b/configure.ac 2022-05-30 12:27:08.688735341 -0400
+@@ -17,6 +17,7 @@
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
+ AM_PROG_CC_STDC
++AC_PROG_LIBTOOL
+
+ if test "x$am_cv_prog_cc_stdc" = xno ; then
+ AC_ERROR([the C compiler doesn't handle ANSI-C])
+--- a/testsuite/Makefile.am 2022-05-03 03:41:05.000000000 -0400
++++ b/testsuite/Makefile.am 2022-05-30 12:27:08.688735341 -0400
+@@ -5,7 +5,7 @@
+
+ noinst_PROGRAMS = $(TS_PROGS) ex1 ex3 ex4
+
+-LDADD = ../libargp.a
++LDADD = -L../.libs -largp
+
+ EXTRA_DIST = $(TS_SH) run-tests
+ CLEANFILES = test.out