summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-04-26 18:51:01 +0800
committerJason Zaman <perfinion@gentoo.org>2018-04-26 19:22:26 +0800
commit6b569c53e519c5f28d481d1ec04159183c2a0cd5 (patch)
tree7cd7b516de629ecca767a1d08def776d25a21bd2
parentsys-apps/semodule-utils: bump to 2.8_rc1 (diff)
downloadgentoo-6b569c53e519c5f28d481d1ec04159183c2a0cd5.tar.gz
gentoo-6b569c53e519c5f28d481d1ec04159183c2a0cd5.tar.bz2
gentoo-6b569c53e519c5f28d481d1ec04159183c2a0cd5.zip
sys-apps/secilc: bump to 2.8_rc1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-apps/secilc/Manifest1
-rw-r--r--sys-apps/secilc/secilc-2.8_rc1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/secilc/Manifest b/sys-apps/secilc/Manifest
index 8d610fad4d51..61d935b0a8c6 100644
--- a/sys-apps/secilc/Manifest
+++ b/sys-apps/secilc/Manifest
@@ -1,2 +1,3 @@
DIST secilc-2.6.tar.gz 174543 BLAKE2B a540fc1b0e1821bb5177be57904602280ec8808c1cd4248385850db288493390e1340e637b98cfa75d27bc4e02555bcb4174b9946c30be160ba6220034befe6e SHA512 5d59320d599d15754d76d36d981a1927d9633db9813f0248c29c9ff38bc59bf394910f4d56444a97df910b48e59f128d9997a85b6bd2ee8e0dd3ae31a9a2b7d0
DIST secilc-2.7.tar.gz 175733 BLAKE2B dfad83618f3dd14f4a710d27b6ff3dbe188c9e1eecabe29dd16d9b0ba35a2aa2c5777d999fb378159624f7b7af9af152592e69f9212d2ae6dc6e52dbefcba056 SHA512 cd828ad34e80151951f94414d27246b480cd4831d1d57cb35d5958ce23c30fe74f26ec1c4b29b51fe382bf03ec3144311b35ca645ffc6b914b7abfe677684c06
+DIST secilc-2.8-rc1.tar.gz 175892 BLAKE2B e919e7a519c02e4ff467aa086e1112d26fe2e32d30406ca34859703158d51b473353cd8b6c9825dc824f6fc09774993ab6386390ae2f9262f5afc80a19ca08fa SHA512 c4ed860b4a35bbd4d2e9f20810deea8f8158825e24d55d97c122a8ffda0a7c8c16d84f966e923b371359c807620308e2c7fc10bccb384a94216a7b92d756ac13
diff --git a/sys-apps/secilc/secilc-2.8_rc1.ebuild b/sys-apps/secilc/secilc-2.8_rc1.ebuild
new file mode 100644
index 000000000000..4e6f3c66ad82
--- /dev/null
+++ b/sys-apps/secilc/secilc-2.8_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit toolchain-funcs
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20180419"
+
+SEPOL_VER="${PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/xmlto
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+RDEPEND="
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}