summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-01-13 20:14:12 +0100
committerHans de Graaff <graaff@gentoo.org>2020-01-13 20:24:05 +0100
commit6b60990ce47bac5413aa51712433c46e0ff4e529 (patch)
tree2bbbb92a966d252098769992af3867c1941365aa
parentdev-ruby/tdiff: add ruby27 (diff)
downloadgentoo-6b60990ce47bac5413aa51712433c46e0ff4e529.tar.gz
gentoo-6b60990ce47bac5413aa51712433c46e0ff4e529.tar.bz2
gentoo-6b60990ce47bac5413aa51712433c46e0ff4e529.zip
dev-ruby/rspec-expectations: add ruby27
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
index 1ccac87ba937..afe2e00f7f15 100644
--- a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -51,9 +51,5 @@ all_ruby_prepare() {
}
each_ruby_prepare() {
- case ${RUBY} in
- *ruby24|*ruby25|*ruby26)
- sed -i -e 's/of Fixnum/of Integer/' spec/rspec/expectations/expectation_target_spec.rb spec/rspec/matchers/be_instance_of_spec.rb || die
- ;;
- esac
+ sed -i -e 's/of Fixnum/of Integer/' spec/rspec/expectations/expectation_target_spec.rb spec/rspec/matchers/be_instance_of_spec.rb || die
}