summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-10-04 22:57:04 +0200
committerSam James <sam@gentoo.org>2022-10-13 00:06:27 +0100
commit6b7393da42ee0482c5886b988257c9ceacd7ec9f (patch)
tree11a0ef3109b6aacd3beb67d4c5321421618b79b8
parentprofiles: mask logging USE flag on sci-libs/vtk (diff)
downloadgentoo-6b7393da42ee0482c5886b988257c9ceacd7ec9f.tar.gz
gentoo-6b7393da42ee0482c5886b988257c9ceacd7ec9f.tar.bz2
gentoo-6b7393da42ee0482c5886b988257c9ceacd7ec9f.zip
sci-libs/vtk: fix build on musl
- Add logging USE flag to be able to disable it for musl - Re-keyword temporarily dropped arm64 Bug: https://bugs.gentoo.org/873601 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/27626 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/vtk/metadata.xml1
-rw-r--r--sci-libs/vtk/vtk-9.1.0-r4.ebuild (renamed from sci-libs/vtk/vtk-9.1.0-r3.ebuild)8
2 files changed, 5 insertions, 4 deletions
diff --git a/sci-libs/vtk/metadata.xml b/sci-libs/vtk/metadata.xml
index b4654dc0d664..104d25f0b118 100644
--- a/sci-libs/vtk/metadata.xml
+++ b/sci-libs/vtk/metadata.xml
@@ -21,6 +21,7 @@
<flag name="imaging">Building Imaging modules</flag>
<flag name="json">Support for json formatted data</flag>
<flag name="kits">Build kits in addition to modules</flag>
+ <flag name="logging">Enable the loguru logging module</flag>
<flag name="offscreen">Offscreen rendering through OSMesa</flag>
<flag name="pegtl">Use pegtl to build parsers</flag>
<flag name="qt6">Use Qt6 packages instead of Qt5</flag>
diff --git a/sci-libs/vtk/vtk-9.1.0-r3.ebuild b/sci-libs/vtk/vtk-9.1.0-r4.ebuild
index 7b1132e4e548..f6730684bc66 100644
--- a/sci-libs/vtk/vtk-9.1.0-r3.ebuild
+++ b/sci-libs/vtk/vtk-9.1.0-r4.ebuild
@@ -37,13 +37,12 @@ S="${WORKDIR}/VTK-${PV}"
LICENSE="BSD LGPL-2"
SLOT="0/${MY_PV}"
-# ~arm64 #864791
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
# TODO: Like to simplifiy these. Mostly the flags related to Groups, plus
# maybe some flags related to Kits and a few other needed flags.
IUSE="all-modules +boost cuda debug doc examples +ffmpeg +gdal imaging java
- mpi mysql odbc openmp postgres python qt5 qt6 +rendering tbb test +threads
- tk video_cards_nvidia views web"
+ logging mpi mysql odbc openmp postgres python qt5 qt6 +rendering tbb test
+ +threads tk video_cards_nvidia views web"
RESTRICT="!test? ( test )"
@@ -294,6 +293,7 @@ src_configure() {
-DVTK_BUILD_EXAMPLES=$(usex examples ON OFF)
-DVTK_ENABLE_KITS=ON
+ -DVTK_ENABLE_LOGGING=$(usex logging ON OFF)
# defaults to ON: USE flag for this?
-DVTK_ENABLE_REMOTE_MODULES=OFF