summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-05 04:34:22 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-05 04:34:22 +0100
commit6b7c69d8191118a91d40554bdf2a1c4dab639079 (patch)
treef855d61e12d57438e64b3746fb881ee74d816e97
parentdev-python/waitress: Bump to 3.0.0 (diff)
downloadgentoo-6b7c69d8191118a91d40554bdf2a1c4dab639079.tar.gz
gentoo-6b7c69d8191118a91d40554bdf2a1c4dab639079.tar.bz2
gentoo-6b7c69d8191118a91d40554bdf2a1c4dab639079.zip
dev-python/blake3: Bump to 0.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/blake3/Manifest1
-rw-r--r--dev-python/blake3/blake3-0.4.1.ebuild134
2 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/blake3/Manifest b/dev-python/blake3/Manifest
index 3bd3a67cbbf1..4e454bb165cf 100644
--- a/dev-python/blake3/Manifest
+++ b/dev-python/blake3/Manifest
@@ -5,6 +5,7 @@ DIST bitflags-1.3.2.crate 23021 BLAKE2B eb990bb27b2bdeb66fd7212ce582cb36e1c616de
DIST blake3-1.5.0.crate 168914 BLAKE2B 72d1851f3cbe5c996570f5cf0cb4ab8c4215ac0e95a6b930dd64ff650333a8745ad1b63a2f988227d66a096cafc59777aeec8e63c05a22d666c1bdd58acaa320 SHA512 39c4d3d370bede96b3f4e37c44514dddfd1ef91d178116e1556eb8f3e2687b705e2320f842e600e59229198aeffff4ab1de34eaf59e8a3c039003f13d0f08aab
DIST blake3-py-0.3.4.gh.tar.gz 114853 BLAKE2B 0aee132e7446e2e1727e50b9d50454645798d5f5daafdd5844a2e47f560bfbd23633707c4803b2d8583c3402041dac9115f09648dba251e4a3b570cfb76ea6fb SHA512 9b55249833c0066cc977b292d8e586175a5b3eb14b1619f2b402be960a65b189c8fdee9c5e7b3cfb44af2e588227c9864be1a95d486ad705a182253cae533c27
DIST blake3-py-0.4.0.gh.tar.gz 115883 BLAKE2B 3c2a2148b2eec9a0c24081b445c36c909d2dd80ba19a8afc487622cb16aa599b67feab5ab441f87b6df894f351ce560f17e55df10bf91033a4cff5bc84d70069 SHA512 6ac25d62acb85e3923d4e26651e2dba849452306ccaa4bdbf075b9a8886061c3827f13ab300f77c496a2c83343d1f714e5940772780e7c1bbcb66d5096092114
+DIST blake3-py-0.4.1.gh.tar.gz 116080 BLAKE2B 9fd2db2a573182ec4bab9d6e37750f4afff9b200e2bb9fe4c26e6bfde328ad2aab162d2adcadc312f3e007ddca19d92c73e058466caddf6c7aa7fc10b553f51a SHA512 e166d2d6ac52dac4158e7b494e83398afd692cb8b93951809338f8da26d337506e3ce2bf37528da6960cfab9b6e3f229a2b5e845dd9a83b35028249113869112
DIST cc-1.0.83.crate 68343 BLAKE2B 33245b33fa845ea2f36da36e3830ec835f937e4319865b357ee9d5ea29a0f9f8392eadb38bf1d95e3c15ed201e561acaa87aedcef744f8db3dabff87a96c7f02 SHA512 742a248c3a7547bb220a0b9c97b67a831fab9b4ac21daa08c85a3966b9fe576088def33e16132fcabec9a2828a6fc437088bb045bfc98b2cea829df6742565a7
DIST cfg-if-1.0.0.crate 7934 BLAKE2B e99a5589c11d79d77a4537b34ce0a45d37b981c123b79b807cea836c89fc3926d693458893baca2882448d3d44e3f64e06141f6d916b748daa10b8cc1ae16d1b SHA512 0fb16a8882fd30e86b62c5143b1cb18ab564e84e75bd1f28fd12f24ffdc4a42e0d2e012a99abb606c12efe3c11061ff5bf8e24ab053e550ae083f7d90f6576ff
DIST constant_time_eq-0.3.0.crate 11369 BLAKE2B a6fb4ad3146b26bb3e18458938e65133431df129963041465291b38a69ba2b53ffcc849f455e67a65a5291803591b350afe4ad4996f1c4cb76c18a987b5b3ee2 SHA512 77bf6817c521daa45c0df7721418b4aa367531adde46b1db97316d52ffb46fc4ee2d3e6f62ff91ca6292db5e1d3e040f0f5287c3936f12a595b2c8c5928bf5e6
diff --git a/dev-python/blake3/blake3-0.4.1.ebuild b/dev-python/blake3/blake3-0.4.1.ebuild
new file mode 100644
index 000000000000..b2772f15cb9e
--- /dev/null
+++ b/dev-python/blake3/blake3-0.4.1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CARGO_OPTIONAL=1
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+
+CRATES="
+ arrayref@0.3.7
+ arrayvec@0.7.4
+ autocfg@1.1.0
+ bitflags@1.3.2
+ blake3@1.5.0
+ cc@1.0.83
+ cfg-if@1.0.0
+ constant_time_eq@0.3.0
+ crossbeam-deque@0.8.5
+ crossbeam-epoch@0.9.18
+ crossbeam-utils@0.8.19
+ either@1.9.0
+ heck@0.4.1
+ hex@0.4.3
+ indoc@2.0.4
+ libc@0.2.153
+ lock_api@0.4.11
+ memmap2@0.7.1
+ memoffset@0.9.0
+ once_cell@1.19.0
+ parking_lot@0.12.1
+ parking_lot_core@0.9.9
+ proc-macro2@1.0.78
+ pyo3-build-config@0.20.2
+ pyo3-ffi@0.20.2
+ pyo3-macros-backend@0.20.2
+ pyo3-macros@0.20.2
+ pyo3@0.20.2
+ quote@1.0.35
+ rayon-core@1.12.1
+ rayon@1.8.1
+ redox_syscall@0.4.1
+ scopeguard@1.2.0
+ smallvec@1.13.1
+ syn@2.0.48
+ target-lexicon@0.12.13
+ unicode-ident@1.0.12
+ unindent@0.2.3
+ windows-targets@0.48.5
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_msvc@0.48.5
+ windows_i686_gnu@0.48.5
+ windows_i686_msvc@0.48.5
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_msvc@0.48.5
+"
+
+inherit cargo distutils-r1
+
+MY_P=blake3-py-${PV}
+DESCRIPTION="Python bindings for the BLAKE3 cryptographic hash function"
+HOMEPAGE="
+ https://github.com/oconnor663/blake3-py/
+ https://pypi.org/project/blake3/
+"
+SRC_URI="
+ https://github.com/oconnor663/blake3-py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+ rust? (
+ ${CARGO_CRATE_URIS}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="
+ || ( CC0-1.0 Apache-2.0 )
+ rust? (
+"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0-with-LLVM-exceptions BSD-2 MIT Unicode-DFS-2016
+ || ( Apache-2.0 CC0-1.0 )
+"
+LICENSE+="
+ )
+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+rust"
+
+BDEPEND="
+ rust? (
+ ${RUST_DEPEND}
+ dev-util/maturin[${PYTHON_USEDEP}]
+ )
+ !rust? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/blake3/blake3.*.so"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ cargo_src_unpack
+}
+
+src_prepare() {
+ # sed the package name and version to improve compatibility
+ sed -e 's:blake3_experimental_c:blake3:' \
+ -e "s:0[.]0[.]1:${PV}:" \
+ -i c_impl/setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ local DISTUTILS_USE_PEP517=$(usex rust maturin setuptools)
+
+ if ! use rust; then
+ cd c_impl || die
+ fi
+ distutils-r1_python_compile
+ if ! use rust; then
+ cd - >/dev/null || die
+ fi
+}