summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-01-20 13:13:38 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-01-20 13:14:08 +0100
commit6b80a155ec5edca1f0c8c8d15292107638523c07 (patch)
tree084130b4b014d173dd19d231fd4b3bc2f621f49e
parentdev-libs/libfilezilla: add 0.41.0 (diff)
downloadgentoo-6b80a155ec5edca1f0c8c8d15292107638523c07.tar.gz
gentoo-6b80a155ec5edca1f0c8c8d15292107638523c07.tar.bz2
gentoo-6b80a155ec5edca1f0c8c8d15292107638523c07.zip
x11-misc/autorandr: add 1.13.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--x11-misc/autorandr/Manifest1
-rw-r--r--x11-misc/autorandr/autorandr-1.13.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
index b7513c4b18c5..4688ef53ace5 100644
--- a/x11-misc/autorandr/Manifest
+++ b/x11-misc/autorandr/Manifest
@@ -1 +1,2 @@
DIST autorandr-1.12.1.tar.gz 45550 BLAKE2B 5b434325d13c00c3fa70b5d09edb540cdcf3bb921307c60f2c616231e7a87ea85f60e39500ed8116f28619139f71ecc4a8fa153ffadc6b8d74df570736a0d815 SHA512 a7e095eb96e7e0d3a5b3b2122d68a3d3a5121d8be7a86ddd9f837ad42b7a53ed5ee45151f23861c5b900e214a4dfc0c575f45fe70c8c5587562a4035458137a0
+DIST autorandr-1.13.1.tar.gz 47380 BLAKE2B f3173d795294eaa89d4f8c98d8bf6dc6a9c09d57649c228d17759e76d9c15d66b32803a63a07f44090b8d4580af8ae9dd42a3c8ff76d91f47d82f58896aebea6 SHA512 b090de5b4c7ff3d886d6aabac695a694983704678eedb31b4cbfdc88e6569e1f1c4e32ed5d16e59d0c98702c93c8600e7625d4d88dd6c988c7db131364cfb6f7
diff --git a/x11-misc/autorandr/autorandr-1.13.1.ebuild b/x11-misc/autorandr/autorandr-1.13.1.ebuild
new file mode 100644
index 000000000000..c4b2f818767a
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.13.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher systemd udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ $(usev launcher)
+ $(usev systemd)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}
+
+pkg_postrm() {
+ if use udev; then
+ udev_reload
+ fi
+}