summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-28 09:04:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-28 09:54:07 +0100
commit6b925c447db2349c538330d22ab54c0fdc9285ac (patch)
tree68f01d283f528b63d0be8c374c5c80e587d2e044
parentdev-python/boto3: Bump to 1.20.45 (diff)
downloadgentoo-6b925c44.tar.gz
gentoo-6b925c44.tar.bz2
gentoo-6b925c44.zip
app-admin/awscli: Bump to 1.22.45
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.45.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index d8a82367b16f..56f195c7e306 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,3 +6,4 @@ DIST awscli-1.22.41.tar.gz 2149857 BLAKE2B dfa66104b723abae76a98d40d40e67e4d7895
DIST awscli-1.22.42.tar.gz 2150093 BLAKE2B 5773ce97774003868b085814c72dd8471292df8768f2f6bef984d2f110ea2b53f4728d8736c08cd9e928469a779191cfc92362b1076c830787b7872071c461af SHA512 21fa5cd3c0996aeab87124786fad3ad7ebc66f226a42d4aa55e63d0d4f1ec48a380b669c5b92edb5e386a48af30d936efb93e85dae31a79efa0d4c205f331c98
DIST awscli-1.22.43.tar.gz 2150545 BLAKE2B 8c7efa1f4e8c48359733936d45bd90b51e54e993561b5fad33d9e5ee6e5b090c0815fad9f721b0c1bb31e5fa89323d30f45d395558460434c6bfc6ea819ede26 SHA512 bd87523e640d2cb17adb2a132ff965735567ebfb442cfa752f2a7955e953d6e761ba9ca817c7fa9235a44e9b611d195f2c731c858b7cd26bb7aaca935fcc4a57
DIST awscli-1.22.44.tar.gz 2150694 BLAKE2B db7e88a58ff42cf1ebc2b337ae408dd90d80ab49a43358587a2bad84d0ef1916c3abdd35b62c9ffbbce948cf9cf536eb01c23688992a022019e722179bf204b1 SHA512 bd7ed097682010bed80049f67760235402fb6e0b9bb9c26e0ba8032e6a8f5bd7604a847791c6771dc85e0d02272d3fde5f1c34141d8c011c8aded6863ec334d8
+DIST awscli-1.22.45.tar.gz 2151247 BLAKE2B b1f90eb47563d6fe1936fdaa486771778a8e1c2e449e2b6272bfac403100ad72ec53b0ff1925aec9e3e2497040d2998f2034d1d7777a927a68f97da47045a7cc SHA512 3cad811fdaeff8434750887fb3c6a8e6716ae4a1859294d73d25158f14cfe56226ca99994d3eaee1ab5c11a442720c450331948ab64805d33bd0bbec8a8c64d0
diff --git a/app-admin/awscli/awscli-1.22.45.ebuild b/app-admin/awscli/awscli-1.22.45.ebuild
new file mode 100644
index 000000000000..1f3430af8a9f
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.45.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}