summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-07 06:28:15 +0100
committerSam James <sam@gentoo.org>2022-05-07 06:28:36 +0100
commit6b9991027fe5482e56aca0da6453f173e1a19cb0 (patch)
treeb7f220ce0bc88a5081c0ea6c2cd4f58449e43c6a
parentmedia-gfx/krita: add 5.0.6 (diff)
downloadgentoo-6b999102.tar.gz
gentoo-6b999102.tar.bz2
gentoo-6b999102.zip
sys-apps/xdg-desktop-portal: add 1.14.4
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index b3c3a7ac084c..53021bf8d8ca 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1,3 +1,4 @@
DIST xdg-desktop-portal-1.12.1.tar.xz 484352 BLAKE2B afa14ab78f35cb1c0e66514f313f5dc297ceef88af1ca7b3028305faa8398bdae1b9e897289b18a93b1cda1a8290c0e51bf73e66c9dce231f57a58652fb9e120 SHA512 62df427e2d8d54acd9a34a02a77c26ae3911fbb4c5844eff4a253dc839775c929c6945401b93549ba200ba637d315146767e41f18a831d7627b35de880de0da1
DIST xdg-desktop-portal-1.14.2.tar.xz 504088 BLAKE2B e0a378c1f1d80afda7d73fd8e545f7304eeab349cf3298ebb616021c7e16e8a088360681e31eedca9ac90978eb04167a7e857ddaa5e023a2a8c24c9f959f9b2c SHA512 7164d6c0d89843d117e03bc46963d72f24dae2b9fc8e173f06a78bbc80655ccf192d86f951d3c404c88bf5da88d9d2053ea52cf3e541b833ee937b6931d803d7
DIST xdg-desktop-portal-1.14.3.tar.xz 504296 BLAKE2B 9416e6843ed4cb8a3b33f3665ce2cca7b1bf4fc4dfb9ac11bf8b6c0906829df25bcd6a32c68231d36e16f1cbd0181a2d938a06098f00dec34c3981bca943e632 SHA512 ced23bf0973227b5d89ea976aa0978fa16cfa2983dd6b64802714a852dab215584198c04482edaa5a145e292bf7f5b9c5c98ee864fb24abb5bdc48cd1c839a9e
+DIST xdg-desktop-portal-1.14.4.tar.xz 510492 BLAKE2B 32f71cbc74d6bb3010e31172972dd7bfc4c982691ef55f66c29d5cf4aa2abeed816f890800691e898f739c2c7aa13db1e04f322c89ce30e9ac8a69b87435a448 SHA512 23fa4f9fdf39f22d6eaa4f6020db5f81d272b85fe6051467c5e28a752c65b18a9b540fafe5b27725fafa29dffefcd113d873928cd78e3658895cd24d96b82f73
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.4.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.4.ebuild
new file mode 100644
index 000000000000..03615c15f70a
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.66:2
+ dev-libs/json-glib
+ >=sys-fs/fuse-3.10.0:3
+ x11-libs/gdk-pixbuf
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ $(use_with systemd)
+ )
+ econf "${myeconfargs[@]}"
+}