summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-03 10:31:49 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-03 10:49:31 +0200
commit6b9e6902a34774be5da56ac30678386578b97558 (patch)
treea7e86e6007aa87ec5d0f384563a0da4cb5641e42
parentdev-python/junit-xml: Enable py3.12 (diff)
downloadgentoo-6b9e6902a34774be5da56ac30678386578b97558.tar.gz
gentoo-6b9e6902a34774be5da56ac30678386578b97558.tar.bz2
gentoo-6b9e6902a34774be5da56ac30678386578b97558.zip
dev-ruby/rails-html-sanitizer: add 1.6.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rails-html-sanitizer/Manifest1
-rw-r--r--dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.6.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/rails-html-sanitizer/Manifest b/dev-ruby/rails-html-sanitizer/Manifest
index d7dd5173f493..002418af9a5f 100644
--- a/dev-ruby/rails-html-sanitizer/Manifest
+++ b/dev-ruby/rails-html-sanitizer/Manifest
@@ -1 +1,2 @@
DIST rails-html-sanitizer-1.5.0.gem 19456 BLAKE2B 7f8b0270d9006b975fed28941139e176af4738954bd56e7b34dbc4f778521d770ff0c2c92cb365d1a671fc69d1da79f4d3bd4d90e37913c61084139ba7ff9893 SHA512 533a203d34b0f77b70258fc1b610caf1d4910da48224b136774d094ee8fa74b5cd9f3b1719118334489a41d743b97592539935b05b07770cd745e03634422214
+DIST rails-html-sanitizer-1.6.0.gem 23552 BLAKE2B 7bc00cada4bb10a6f3b264a20f555b1e3e81a09d528339f20961ebbd5c958c23a7b14febf8a2e1c07d36e8d67aff30317d2ebc0f9cd009a1b519d24b18a0171b SHA512 265c093872b43794be02a8b1d2574be8270762b46c2b0d930159d3b41e06b897ed8b6edf3b219e0e71591fa5f7d38107ed8d332cebd3dfe4c37c6d06b7b5fa12
diff --git a/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.6.0.ebuild b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.6.0.ebuild
new file mode 100644
index 000000000000..e5a888f40261
--- /dev/null
+++ b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sanitize HTML fragments in Rails applications"
+HOMEPAGE="https://github.com/rafaelfranca/rails-html-sanitizer"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/loofah-2.21:0 >=dev-ruby/nokogiri-1.14:0"
+
+ruby_add_bdepend "test? ( dev-ruby/rails-dom-testing )"
+
+all_ruby_prepare() {
+ # Avoid tests that depend on nokogiri patches to libxml2.
+# sed -i -e '/\(name_action\|attr\)_in_a_tag_in_safe_list_sanitizer/askip "libxml2"' test/sanitizer_test.rb || die
+:
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}