summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-01-30 15:11:44 -0500
committerBrian Evans <grknight@gentoo.org>2020-01-30 16:13:54 -0500
commit6bb127d246d8c6fdc7f18c7f7e908b37e10ade55 (patch)
tree26944ed6615328868266a67f00ba5211915dc434
parentdev-db/mariadb: Version bump for 5.5.67 (diff)
downloadgentoo-6bb127d2.tar.gz
gentoo-6bb127d2.tar.bz2
gentoo-6bb127d2.zip
net-misc/omnisync: New snapshot to fix -fno-common
Closes: https://bugs.gentoo.org/707498 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--net-misc/omnisync/Manifest1
-rw-r--r--net-misc/omnisync/omnisync-1.0_p20200130.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/omnisync/Manifest b/net-misc/omnisync/Manifest
index cae6a303707e..12cf08cb129f 100644
--- a/net-misc/omnisync/Manifest
+++ b/net-misc/omnisync/Manifest
@@ -1,2 +1,3 @@
DIST omnisync-1.0.tgz 27725 BLAKE2B 00e546e3a04c8483f4a3995207fe6715e25526ca639f517220725c31d50d1c01fe0d15927e11e84143f3b2c8aa80ede1317c818945f0249147548bb03d27f744 SHA512 742ffc0a85bd923b99ae7e4f50a6aaa29107eaa987039e902797c78a9673e914e1fa61b2484c6777f62b0caf8b3110a071fd103c8b18456083883df534a1ef4d
DIST omnisync-1.0_p20180614.tar.bz2 26335 BLAKE2B fbb6e4d39f16e307b5355c1e25c656bfdd3b280888468e64bed692c52af28b35d813e3e5a19c6dd4c13bfa8c64b62f01826bdb8a4a40f358cc665e5050ccfbf1 SHA512 fd21907574abe9801999efa8dae6e19e80198536cd79a1261cd2c006b7beaa3637f5b9da578659baa9e14eca1756fa41551458f14bad44f9636d76634031f262
+DIST omnisync-1.0_p20200130.tar.bz2 26360 BLAKE2B 4b999caf66f63f02241781234c88f8de54b727c9ce116afe77f6cc84e75146b0a748c8ecfe236009ad3704ead46d787cf3c06b556b2ffbecbed37c39322dcdf7 SHA512 b9f66755e990f1ffe2f2524f122581ff397f299f26b4e7d1301e649a1430b2ea814b39b4370621f1281c0b0fdab7aa026d1f827aeb7cfa4993286ad86484a4e8
diff --git a/net-misc/omnisync/omnisync-1.0_p20200130.ebuild b/net-misc/omnisync/omnisync-1.0_p20200130.ebuild
new file mode 100644
index 000000000000..c0a9f2f3dae6
--- /dev/null
+++ b/net-misc/omnisync/omnisync-1.0_p20200130.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake vcs-snapshot
+
+SNAPSHOT="c55215330b1e8a61af6d34d57d3d8236c8cc7d5b"
+
+DESCRIPTION="A driver for NTPd for people who are firewall-challenged"
+HOMEPAGE="https://www.vanheusden.com/time/omnisync"
+LICENSE="GPL-2"
+SRC_URI="https://gitlab.com/grknight/omnisync/-/archive/${SNAPSHOT}/omnisync-${SNAPSHOT}.tar.bz2 -> ${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-libs/gnutls:= net-analyzer/net-snmp:="
+DEPEND="${RDEPEND}"
+DOCS=( readme.txt Changes )
+
+src_install() {
+ cmake_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ einstalldocs
+}
+
+pkg_postinst() {
+ local isConfigured=$(grep 'OMNISYNC_MODE=""' "${ROOT}/etc/conf.d/${PN}")
+ if [[ -n "${isConfigured}" ]] ; then
+ elog "Be sure to configure ${PN} in ${ROOT}/etc/conf.d before trying to start the service"
+ fi
+}