summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-16 19:04:50 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-16 19:38:15 -0600
commit6bbd82c8ad6bb5971fc77d472b5392137c678140 (patch)
treeb6e95853a879aeb3bce56c84981c0d404f3351b2
parentdev-python/oslo-db: 4.33.0 bup (diff)
downloadgentoo-6bbd82c8ad6bb5971fc77d472b5392137c678140.tar.gz
gentoo-6bbd82c8ad6bb5971fc77d472b5392137c678140.tar.bz2
gentoo-6bbd82c8ad6bb5971fc77d472b5392137c678140.zip
dev-python/oslo-policy: 1.33.1 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/oslo-policy/Manifest1
-rw-r--r--dev-python/oslo-policy/oslo-policy-1.33.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/oslo-policy/Manifest b/dev-python/oslo-policy/Manifest
index 80323a4bb5c3..084ddb9eec5b 100644
--- a/dev-python/oslo-policy/Manifest
+++ b/dev-python/oslo-policy/Manifest
@@ -1 +1,2 @@
DIST oslo.policy-1.25.2.tar.gz 72984 BLAKE2B 7f2e4d48309082c1069ffcb561502c71b86e0c5508bb07cff943a1fc32fbbec8a232451937b678842909779e94b7eecdd5f2991152e0c8ca557a58b1ce137fc7 SHA512 8d66fe73d7b9d381c54997d980833e4e5d429a9ca28343adf777af20042694bf5dd878f9c1a9ed7168c075816e4b37263f9b520274bbdccbe0c6649b7cd7d213
+DIST oslo.policy-1.33.1.tar.gz 74314 BLAKE2B dda781284b77a6677f9a5dd55473bc239a5b482e635a8e0e808f918ad7aa6f2a8178676f9584a15c418cad373e9f34f6a24bfc462c053f06d0993786fb5ede0d SHA512 50d2c146afe04f669c0d7f3e7309a9d03883ca72fece4135e20f7d8a75b71a5a69b9b5b26e36b6afb0fd162c4ddcc5566c08cdf26dbf3bd9679f5ff75c27d722
diff --git a/dev-python/oslo-policy/oslo-policy-1.33.1.ebuild b/dev-python/oslo-policy/oslo-policy-1.33.1.ebuild
new file mode 100644
index 000000000000..16797b7c55cf
--- /dev/null
+++ b/dev-python/oslo-policy/oslo-policy-1.33.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support for RBAC policy enforcement across all OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.policy"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.policy/oslo.policy-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.policy-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}