summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-08 15:37:49 +0000
committerSam James <sam@gentoo.org>2021-02-08 15:38:12 +0000
commit6bbd9bcac960a51bee28bdff7b7e5e8fa29b3740 (patch)
tree9df944426a6878cfd5a240b2818b9fd2cc68511c
parentdev-ml/opam: add ml@ (diff)
downloadgentoo-6bbd9bca.tar.gz
gentoo-6bbd9bca.tar.bz2
gentoo-6bbd9bca.zip
dev-ml/opam: bump to 2.0.8
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/opam/Manifest1
-rw-r--r--dev-ml/opam/opam-2.0.8.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
index 9556c2492a09..bf98012b0402 100644
--- a/dev-ml/opam/Manifest
+++ b/dev-ml/opam/Manifest
@@ -1,2 +1,3 @@
DIST opam-1.3.1.tar.gz 669485 BLAKE2B e1aed54175d46f5dd9fd989e56c25657370356e26df6976c01dd089e381291fa04e25da295104f85d513010cd028276d80ebf7a4a77b38f3e089e52f4e64f43a SHA512 d075c9b2c9670d712f29bd2df34b8020da52041fa2bbef599cb54a81f63554507d78bebece45ecf668d3d1d4ed514e4ab88a1d86b64088d283bca7a8e75ae582
DIST opam-2.0.7.tar.gz 636708 BLAKE2B 2824a5c53f4103c267f99ae10f55df740b3afcc033321e888133817c0e53c4a8fc31738338df3d6d9ff8755987e85ade4a4726be98f77b06b81ffc1476d02c3d SHA512 2ade3998a94333a5a838b55e229ab0c707e678481cae892980b986fb86f39163070a9b7d3e0e87879cd57b91a33bf6a3e15f3786c3510a635e59383782218f1d
+DIST opam-2.0.8.tar.gz 643221 BLAKE2B 66510a18285f315fe95665e8ba2f334dd44211c716543cdc25f2951a7dfe537f115981046e5963fd08deea4c76f5672fa7cf8e7af2274a713a3165bdd0bac8c2 SHA512 14737dc994be2c54dfeaf2658d3713178033e1bc2b4b845a58b4bfc118bbbf12b502924add0ae32b4b2b6c1944462e5ee7143df3de362d9ee39573249d013bc9
diff --git a/dev-ml/opam/opam-2.0.8.ebuild b/dev-ml/opam/opam-2.0.8.ebuild
new file mode 100644
index 000000000000..32c8aa658a33
--- /dev/null
+++ b/dev-ml/opam/opam-2.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ dev-ml/dose3:=
+ dev-ml/extlib:=
+ dev-ml/opam-client:=
+ dev-ml/opam-file-format:=
+ dev-ml/re:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}