summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-25 06:13:30 +0000
committerSam James <sam@gentoo.org>2021-04-25 06:18:39 +0000
commit6bc3d5aa7293ba9643c793f52c544fdeeaf47821 (patch)
tree66f8ab8a7e3a8c9e6bffe619285caf9ed2be56c9
parentsys-fs/compsize: sync live ebuild for KEYWORDS (diff)
downloadgentoo-6bc3d5aa.tar.gz
gentoo-6bc3d5aa.tar.bz2
gentoo-6bc3d5aa.zip
dev-libs/libofx: add 0.10.2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libofx/Manifest1
-rw-r--r--dev-libs/libofx/libofx-0.10.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/libofx/Manifest b/dev-libs/libofx/Manifest
index 3fe202d0c09d..db53570ab1e2 100644
--- a/dev-libs/libofx/Manifest
+++ b/dev-libs/libofx/Manifest
@@ -1 +1,2 @@
DIST libofx-0.10.1.tar.gz 226512 BLAKE2B bc0fa1ea0d5c7968730b50b9163a045304dd82f7e312e407ce9393a56ea6b1f9d47382b1299ee990640b98d5f047656aa38a9a8da4d8f19d3bea0236e0487cf1 SHA512 4575424abb56b93021ef223f90460979b544c32b4624936bbad16d0b5711afb6b5fa31b7c2cb835ff7a26be8c7ac51951198e5565a098713b8d33f0e17be774a
+DIST libofx-0.10.2.tar.gz 225043 BLAKE2B 2ca8cdd9913f2bddb60600d75acfb114d56d6c59191fe2b836a0c2a988b6d0404821a9f99be1fa4b258afbbc35b0cb254b348a1e7a0f7a8c4010645afff52f91 SHA512 14ba2779d94209312a8a1bbf598e6a31820df4fa7e222ae1abb8d4234a6c7ba7068e06a73ad4ee93bcb53ccb99a8007d799d9e66a9921704dc75c84b0e7dc307
diff --git a/dev-libs/libofx/libofx-0.10.2.ebuild b/dev-libs/libofx/libofx-0.10.2.ebuild
new file mode 100644
index 000000000000..ae5c04394d48
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.10.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Library to support the Open Financial eXchange XML format"
+HOMEPAGE="https://github.com/libofx/libofx"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/10"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( app-crypt/gnupg )
+"
+RDEPEND="
+ >app-text/opensp-1.5
+ app-text/openjade
+ >=dev-cpp/libxmlpp-2.40.1:2.6
+ >=net-misc/curl-7.9.7
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # Not included in the tarball
+ sed -i -e '/INSTALL/d' Makefile.am || die
+
+ # bug #566456
+ append-cxxflags -std=c++14
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc html-docs) \
+ --disable-static
+}
+
+src_compile() {
+ emake -j1
+
+ if use doc ; then
+ emake doc
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.a' -type f -delete || die
+}