summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRunney <an9wer@gmail.com>2023-10-07 12:52:57 +1030
committerYixun Lan <dlan@gentoo.org>2023-10-08 03:56:49 +0000
commit6bc97529f09b9b8dec6106b94a4013e34e0ed2b2 (patch)
treeca70d81c9e0855e31825abceaca27b162ea0811d
parentdev-vcs/stgit: drop 2.3.1 (diff)
downloadgentoo-6bc97529.tar.gz
gentoo-6bc97529.tar.bz2
gentoo-6bc97529.zip
app-shells/loksh: add 7.3
Closes: https://github.com/gentoo/gentoo/pull/33222 Signed-off-by: Runney <an9wer@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-shells/loksh/Manifest1
-rw-r--r--app-shells/loksh/loksh-7.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-shells/loksh/Manifest b/app-shells/loksh/Manifest
index 4a0cd57d26f5..59dda23bd902 100644
--- a/app-shells/loksh/Manifest
+++ b/app-shells/loksh/Manifest
@@ -1 +1,2 @@
DIST loksh-7.1.tar.xz 211636 BLAKE2B 7604d6a5d3d3bce7dc51cde1d53ec10b927411afe700192e243e8dc022011cb3d89668768ba7940af22e97d95fd074638860e7b74fcacc8c83de4ad995654da4 SHA512 f46221f765f2799856049fbfe1650e6f3d13d597cf97843d4b54b9803b9ecedbf8a8c9364e1ba9b981b667004a8fe4da043006945f8b61f094678d3578518716
+DIST loksh-7.3.tar.xz 212120 BLAKE2B 2c1c56dcbfa664aa894b1f09f145b28f6861bf28f06274f32697eace30f24660dbcecdcf58938f6cae106e654d200ef0cb4cb2ecd309f3d60be4afc7fa6a6b9c SHA512 a054917c975f65dfb5f8eb35665044ddacacdbd2d1e1113e6bf62d5cd8d5f4fd775ff5f20e28191d2417016684a310f23115af102b834aa33083e2be41034477
diff --git a/app-shells/loksh/loksh-7.3.ebuild b/app-shells/loksh/loksh-7.3.ebuild
new file mode 100644
index 000000000000..f591c53b2237
--- /dev/null
+++ b/app-shells/loksh/loksh-7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/loksh/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+src_prepare() {
+ default
+ sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}